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WMi 2013 or Later Configurable Collate  
Integration with eFORMz 

 
 
 
Complete the following instructions to test and configure your WMi Configurable Collates on a Windows system prior to 
implementation on an iSeries server.  
 
Prerequisites 

 A Windows operating system with eFORMz installed 

 Authorization on the AS/400 and Windows systems 

 WMi Configurable Collate files (user data and reference files) 

 XML editor or plain-text editor that supports UTF-8 encoding 
 
Figure 1 displays the WMi Configurable Collate components and their relationship for integration with eFORMz: 
 

 
Figure 1. Components of the WMi Configurable Collates. 
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Download Required Files 

1. Start the eFORMz Composer on your Windows system. 
2. Click Host Tools > AS400 > Download a File to download the WMi configurable collate files from your iSeries 

system. Download the following two files: 

 User Data Spoolfile (CXXXXXXXXD) containing multiple pages of packing slip or label content, which 
might include the packing slip, warehouse label, shipping label, or similar data). Save this file with an 
extension of .scsz to a folder on your Windows system. 

 Reference data file (CXXXXXXXXR). Save this file with an extension of .scsa. 
 

Create an eFORMz Project  
After downloading the required files, the next step is to create an eFORMz project so you can customize your WMi 
collates: 
 

1. Start the eFORMz Composer and create a new project by clicking File > New Project.  

2. Click File > Save Project As. Name the project collate.efz. 

3. Right click the project icon in the Composer and click Add Page > OK. 

4. Right click the new page and click Add Form > Blank > OK. 

5. In Form Properties, select a page size and orientation. Click Suppress output when empty. If you require a 

custom page size, contact Minisoft for guidance in updating eFORMz_User.xml. 

6. Open your .scsa reference file in the eFORMz Composer by right clicking the form > Display Form and Data > 

From file > select the .scsa file > OK. You use this file to gather your cross reference types for reference in the 

eFORMz composite data file (.cdf). The Composer shows the .scsa file like this: 

  
C00000001NUSLGPKSLPC1 

C00000001NUSLGPKSLPC1 

C00000001AUSLGSHLBL01 

C00000001PUSLGSHLBLWHS 

 

You might have more or fewer lines, depending on the contents of your reference data spoolfile. Each line identifies a 

component of the collate document, which are contained in the .scsz data file. Minisoft recommends working with a file 

that contains all components. 

 

Each entry has the format of C########N, where ######## is a group number and N is a content type. The group 

number identifies items that are grouped together, such as packing slips and shipping labels. Type identifies the content 

type, such as packing slips and shipping labels in each group. In the following example, the group number is red, and the 

content type is green: 

 
C00000001NUSLGPKSLPC1 = Packing Slip Page 1 

C00000001NUSLGPKSLPC1 = Packing Slip Page 2 

C00000001AUSLGSHLBL01 = Shipping Label 

C00000001PUSLGSHLBLWHS = Warehouse Label 
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Create the Composite Data File (CDF) 

Use the data in the reference data file (.scsa) to create a composite data file (.cdf) using a XML editor.  
 
The CDF contains XML components that links the user data spoolfile with the reference spoolfile. The CDF is only for 
development work and is not used on the iSeries server. The CDF lets the eFORMz Composer emulate the iSeries 
environment on your Windows system for development.  
 
Your .cdf file should resemble the following sample: 

 

<?xml version="1.0" encoding="UTF-8"?> 

<CompositeData> 

<Data FileName="C:\Minisoft\eFORMz_6\projects\Collate\Data.scsz" /> 

<Reference FileName=" C:\Minisoft\eFORMz_6\projects\Collate\Data.scsa" /> 

<Configuration GroupIdStart="1" GroupIdLength="8"> 

<Component Type="data" Name="" MatchText="C????????N*" Format="SCSZ" /> 

<Component Type="secondary" Name="ShippingLabel" MatchText="C????????A*" Format="SCSZ" /> 

<Component Type="secondary" Name="WarehouseLabel" MatchText="C????????P*" Format="SCSZ" /> 

<Variable Name="ProfileID" Start="10" Length="4" /> 

<Variable Name="LabelFormat" Start="14" Length="10" /> 

<Variable Name="FormatType" Start="9" Length="1" /> 

</Configuration> 

</CompositeData> 

 

Complete the following steps to create your CDF. 

1. Copy the CDF sample from this section. 

2. Open an XML editor and paste the CDF sample. 

3. Save the file as Data.cdf. The file must be encoded as UTF-8. The CDF begins with a standard XML header that 

includes the encoding type. Changing the encoding in the header does not change the encoding of the document. 

You can specify the encoding type at the bottom of the Save As window in Notepad: 

 

 
4. Modify tag attributes and add tags as needed to match your data. Table 1 shows the tags and their attributes that 

are used in the sample CDF file. 

 

Table 1. CDF Tags and Attributes 

Tag Attribute Description 
Data FileName Specifies the path and name of the .scsz file (User Data File). 

Reference FileName Specifies the path and name of the .scsa file (User Reference File). 

Configuration GroupIdStart Names the starting position (0 based character positioning) of the group 

number that groups different content, such as packing slips and shipping 

labels, together.  

Configuration GroupIdLength Number of characters in the group number. 
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Component Type Identifies whether the component in the Name attribute is data (main 

component) or secondary. A value of data indicates the component is the 

main reference to the packing slip. A value of secondary indicates a 

component of the packing slip (shipping label, warehouse label, package 

barcode label, etc.). The component is identified in the Name attribute. 

Component Name Descriptor name specifying the component type if Type = “secondary”.  

Component MatchText The ID number of the group. Use a question mark (?) to represent any single 

character. Use an asterisk (*) to represent any number of characters. For 

example, C????????N* represents all packing slip composite files. The letter 

in the tenth position is the format type. Default format types are listed here: 

 

Letter 

 

Format type 

A Shipping label 
B COD label 
C Address label 
D Oversized label 
E Consignee label 
F Collect label 
G Returns label 
H Saturday delivery label 
I Neutral label 
J Signature label 
K Express cheque label 
L Dry ice label 
M Prepack label 
N Packing slip 
O Packing slip 
P Custom format 

 

Component Format The encoding format of the data. 

Default Variables 

Variable Name ProfileID 

LabelFormat 

FormatType 

Variable Start The starting character position for the ProfileID, LabelFormat or FormatType. 

Variable Length The number of characters in the ProfileID, LabelFormat or FormatType. 
 

 

5. Create a component tag for each component type in your .scsa reference file, and then save the file with a .cdf 

extension. 

 

Table 2. Composition of the Component Code 

Item Default Position Example values 
Carton ID A letter and 8 digits C00000000 
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FormatType 10  A – Shipping label 

 N – Packing slip 

 P – Warehouse label 
 

See Table 1 for a complete list. 

ProfileID 11 through 14 USLG 

LabelFormat 15 to the end  PKSLPC1 – Packing slip 1 

 SHLBL01 – Shipping label 1 

 SHLBLWHS – Warehouse label 
 

 

7. Open the CDF file as your project data file by right clicking the form > Display form and data. Select the Data.cdf file 

and click OK. Contents of your User Data File (.scsz) are shown: 

 

 
 

If you receive the following error message “Error Reading…..The system cannot find the path specified,” check the 

following entries in your .cdf file for the correct data and path references: 

 
<Data FileName="C:\Minisoft\eFORMz_6\projects\Collate\Data.scsz" /> 

<Reference FileName=" C:\Minisoft\eFORMz_6\projects\Collate\Data.scsa" /> 
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Create Project Files for Secondary Components 
 

Now you are ready to customize your WMi shipping document. To customize the location of secondary components 

such as shipping labels and warehouse labels, create a project file for each secondary document type. To keep your 

files organized, save the main component project and secondary projects in the same folder. Write down your 

document types and MatchText value to use later. 

 

Table 3. Examples of Secondary Components 

MatchText Value Document Type Project File Name 
C????????N* Packing slip Collate.efz       (main project) 

C????????A* Shipping label Label4x6.efz    (secondary project) 

C????????P* Warehouse Label4x1.5.efz  (secondary project) 

 

 

Create an eFORMz Project 

Complete the following steps to create a project for the secondary component project (for example, a shipping 

label): 

1. Start the eFORMz Composer. 

2. Click the New Project icon:  

 
3. Right click the project icon > Add Page. 

4. Right click the page > Add Form. 

5. Click Blank > OK. 

6. Right click the form > Display Form and Data. 

7. Select the .scsz file and click OK. 

8. Click the arrows on top of the eFORMz Composer Viewer to go to the page that contains the component data. If 

you are unsure which page of data contains the matching component for the project file you are building, open 

the corresponding .scsa data file and look at which line contains the component reference: 
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C00000001NUSLGPKSLPC1 = Packing Slip Page 1 

C00000001NUSLGPKSLPC1 = Packing Slip Page 2 

C00000001AUSLGSHLBL01 = Shipping Label 

C00000001PUSLGSHLBLWHS = Warehouse Label 

 

Each line represents a data page. If, for example, you are trying to create a project file for the secondary 

component “Shipping Label”, based on the above example, look at page 3 of the .scsz data file. 

 

9. Make necessary adjustments to the project. 

10. Save your project. 

11. Repeat this procedure for each secondary component. 
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Put It All Together 
Complete the following steps after you create the secondary projects: 

1. Reopen your main component project, collate.efz. 

2. Create a new rule to place the secondary project in the custom location. Right click the form > Add Rule > 

Output from Project. 

 
 

3. Type a name for the rule that includes the component type. Select N/A in the Use variable field. Click OK. 

The Output From Project Action window opens. 
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4. In the Output From Project Action window, specify the project location on your Windows system in the 

Project field. This path might be different than the path on the WMi system. 

 
 

After you complete testing on Windows, you must update the project paths for each Project reference in an 

Output from Project Action with the iSeries path. 
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5. Click Input is from a component of a composite data file. The composite data file is your CDF. 

6. If you want the input rotated, select the degrees of rotation in the Rotation field. 

7. In the Component field, type the value of the Name attribute of the Component field. The following example 

shows a component value of ShippingLabel: 

 
<Component Type="secondary" Name="ShippingLabel" MatchText="C????????A*" Format="SCSZ" /> 

 

 

8. Click OK. Your secondary component is shown in the eFORMz Viewer: 

 
 

9. Create an Output from Project rule for each remaining secondary component. The screen shot below shows 

a rule for a ShippingLabel component and for a WarehouseLabel component: 
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After you configure and test your project, update the project paths for each Project reference in an Output 

from Project Action with the iSeries path, and then upload all projects to your iSeries system using the 

following procedure: 

1. Click Host Tools > AS400 > Upload a file. Start by uploading collate.efz. 

2. Enter the WMi system’s IP address and your authentication information. Click Connect. 

3. Find the location to store your project file (usually /minisoft/projects), and upload the file. 

4. Upload each secondary project file the same way. 

 

 

Director Toolkit Configuration 
 

Manhattan provides the WMi20XXeFormzConfig.cfg to its customers to configure the Director Toolkit on iSeries. File 

names have a year that matches the version, for example, WMi2013eFormzConfig.cfg. This Director Toolkit 

configuration file is already configured but might need to be adjusted for any missing component references. 

 

Complete the following steps to set up your Director Toolkit configuration file or, if necessary, adjust any component 

references. 

1. Open the AS400 Director Toolkit (Host Tools > AS400 > Director Toolkit) and open the configuration file.  

2. Right click the File Selection step > Change. 

3. Click ZPLII embedded in SCS. 

4. For the Additional File Selector, select WMi Collate File Selector, and then click File Selector Properties. 

5. On the Files tab, enter the following values: 

Start position:    1 

Length:     8 

Data file selector match string:  C????????D 

Reference file selector match string: C????????R 

6. On the Components tab, click New or Edit (if editing an existing entry), enter a name and MatchText value for 

each secondary component. Click OK after each entry. These are the secondary components that you wrote 

down in “Create Project Files for Secondary Components”. Use the same names and values. For example: 

Name   MatchText value 

PackingSlip  C????????N* 

ShippingLabel  C????????AHSOSSH* 

PackageBarcodeLabel C????????PHSOSORMDIND* 

ReturnInfoLabel  C????????PHSOSRTRNINFO* 

 

7. On the Variables tab, click New, and enter a name, start position, and length for each variable. Click OK after 

each entry. The following list shows the default variables and their attributes: 

 

Variable Start position Length 

FormatType 9  1 

ProfileID 10  4 

LabelFormat 14  10 
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The following image shows how to enter the FormatType variable: 

 
 

And the completed Variables tab: 

 
 

8. Click OK to close the WMi Collate File Selector Properties window. 

9. Click File > Save Configuration to save your changes.  

10. Start the Director. 

 


