Configuring RedPrairie
Purchase Order output for
Emailing



Why the need to configure?

RedPrairie’s (formerly Ecometry) purchase order output for emailing, contains little
formatting of it’s data and no ability to add a purchase order form to the data output for
emailing. With eFORMz, a RedPrairie client can now utilize the RedPrairie output to
format the data, add a form, and email a pdf file to their vendors.

Configuring eFORMz for RedPrairie’s
Purchase Order output

To configure RedPrairie’s purchase order output for emailing using eFORMz, a
RedPrairie user must be on version 8.03 or later of eFORMz. With the eEFORMz
installation, a sample purchase order template (purchase_order _email.efz) will be made
available. Also included, is a sample purchase order template (Rich Text Format) that can
be edited and refreshed to your company look and feel.

Once eFORMz has been installed, open the eFORMz Composer:

1. From your Start menu, open the eFORMz Composer by selecting Programs >
eFORMz 8 > eFORMz Composer:
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2. From the eFORMz Main Menu select File > Open Project.

-
B Minisoft eFORMz Composer (8.03.08), Licensed to Minisoft, e

File | Project Run HostTools Window Help
|~ Open Project..
° MNew Project... —_
e
Save Project f—
Save Project As...
System Properties
C:\MinisoftieFORMz_B8\Projects\Samplel\sampstm.efz
C:\MinisofleFORMz_B8\Projects\Sample\samppo.efz
C\MinisoftieFORMz_B\Projects\Sample\sampinv.efz
C:\MinisoftieFORMz_B8\Projects\Sample\sampchk.efz
Exit
L T Er

3. Open the following purchase order template by selecting:

C:\Minisoft\eFORMz_6\Projects\SoftwareProvider Templates\RedPrairie\
DirectCommerce\po\purchase_order _email.efz

r@, Open u1
Look In: ||j purchaseorder |V|

D purmase_order_email.ed

File Mame: |purchase_0rder_emai|.et |

Files of Type: |eFORszrojectﬁIes |V|

| Open || Cancel |
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4. The template will display in the eFORMz Composer.

.
& Minisoft eFORMz Composer (8.03.08), Licensed to Minisoft, eDIRECT PLUS Enabled

File

Project Run HostTools Window Help

—
[ project

& purchase_order_email -
9 [ Paget

o [5] Document Template

<]

Project | eDIRECT PLUS

z00o004TE -
053/14/12 L
Net 30 DAYSE

[=8 open Datg|

[ [LEE

EMCAS760_0315_0101.5¢ 1= 35460111940

¢ [ PurchaseOrder
o [#] variables T Page
o [E] Rules [} PAGENUM = 01

[CF PONUM = 200000478

[} DATE = 03/14/12

[OF TERMS = Met 30 DAYS

[Of SHIPVIA = PICK-UP

[0F FOB = Snohomish

[} DATEREQ1 = 03/14/12

[Df VENDORNUM = VENDOR# MINZI0W

¢ [f VendorAddress

[} VendorAddress = JOHN DOE
[F ShipToAddress
[} VendorAddress = MINSFT
[OF shipToAddress

[«]

1024 First Street

VENDOR FAX N

PICE-UP Snohomish, ¥Washington 88280
g*;“llzm i : h ORDER DATE TERMS SHIP VIA FO.B.
HII(IZS’D’U B/14s12 Met 30 DAYS PICK-UP Snohom sh
| Il | I*]
MINZ90W

DOE

JOHN

[4]

oot (kb |
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PurchaseOrder |
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eFORMz Preprocessor

In order for e(FORMz to format the data, the Replace occurrences of a string, Text file
pagination and Text to XML Converter preprocessors needed to be added. To view these
configurations, select Project Properties > Advanced.

Replace Occurrences of a String

The Replace occurrences of a string preprocessor finds the form feed in the data file and
replaces it with an at sign. The replacing of the form feed allows eFORMz to handle the
formatting and page breaks.

r hl
Replace Preprocessor Properties &J

Search for |\f |

Replace with |@ |

[ ] Case sensitive search

| oK | ‘ Cancel ‘

Text File Pagination

The Text file pagination preprocessor is utilized to force a line termination after every
84th column. Forcing a line termination allows the text file to “wrap” and the data to be
formatted for later use in changing the file from text to XML.

L8 M
Text File Pagination Preprocessor Properties M

Search string |— |

Search column |0

Maximum lines per page |0 *

Maximum columns perline |84 *
*0=no maximum

Mew page sequence |1f |

=]
=

| ‘ Cancel |
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Text to XML Conversion

The Text to XML preprocessor converts the Ecometry data output to XML. The purchase_
order_email.efz template utilizes a specific configuration for RedPrairie purchase orders.

i Project Proper;ies - P " | = |1

r Printer Control |/Sort r Notes r Data Parsing eranoed r Images |/ Databases

4

Line Termination: [_| Translate CRto CR/LF [ ]| Translate LF to CRILF

Image output type |Gra].-'scale |v| Image output resolution (96
Page Rotation® * AFP and IPDS only

Minimum page number size |0

[] Load initial page number from a file

Initial page number file I:I

[ Update initial page number file after printing/output

rPreprocessor
Replace occurences of a string | MNew | | Move Up | “
Text file pagination -
o | | Textto XML Converter :| Edit ]:IJ Move Down |
| Remaove | | Deactivate |
| OK | ‘ Cancel ‘

To edit the Text to XML Converter Properties, select Project Properties > Advanced. Pick
the Text to XML Converter and select the Edit option.

" -
Text to XML Converter Properties u

ConﬁgurationFiIe| || |

Stock Configuration Fi|e|Red Prairie PO Email |v|
Record Delimiter |\n
Character Set|IS0-8859-1 v

Show editor while in composer

| OK | ‘ Cancel ‘




Modifying the form template

The purchase order project file contains an RTF (Rich Text Format) template form. The
template form can be edited through Microsoft Word and imported into eFORMz.
1. Open the purchase order template form from the following default directory:

C:\Minisoft\eFORMz_6\Projects\SoftwareProvider Templates\RedPrairie\
DirectCommerce\po\purchaseorder.rtf

2. The RTF file will display in Microsoft Word:

W = = PurchaseOrder [Compatibility Mode] - Microsoft Word
Home | Inset  Pagelayout  Refersnces  Mailings  Review  View  Acrobat
= =
. - - -y - (2, = [s
=) Arial 3 AN A 2 AaBbCCDAE | AaBbCEDAE Ad]j %
Pastt . B J U -abe X, X' - A A iMormal | Mo Spaci... Title — Chang
- 2o 7| styles+
Clipboard Font Faragraph styles
VENDOR FAX NO. PURCHA SE ORDER N{
Snohomish, Washington 98250
ORDERDATE [TERMS SHIF VIA F.O.B. DUEDATE
SHIP NO LATER
PATMENTTYPE SHIPPING INSTRUCTIONS
v VENDOR NO.
E
N
D
o]
R
ITEM et DATE UNIT EXTE
NUMBER QUANTITY | o DESCRIPTION REQUIRED FRICE MG




3.
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Make any necessary modifications.

r N
[T D R NES PurchaseOrder [Compatibility Mode] - Microsoft Word Fext Box Tools @Eu
Home | Inset  Pagelayout  Referemces  Mailings  Review  View  Acrobat Format o @
= s A
_j . Arial 8 A A sasocence | assoceoe AAA B % il
Paste B 7 U -abe % x* i Normal | T No Spaci.. Title —| Change Editing
- 7 styles~ | -
Clipboard Font Styles n
Lix]
-
¥ * PURCHASE ORDER NO..
: 1024 Second Street |
L Snohemish, Washington 98290 L
ORDERDATE [TERMS |5HIPV1A ‘F.CI.B. DUEDATE
SHIP NO LATER
PAYMENT TYPE
SHIPPING INSTRUCTIONS
v =
E
N
D
o]
R
ITEM L DATE UNIT EXTENDED
NUMEER QUANTITY | o e DESCRIPTION REQUIRED PRICE AMOUNT
|
-
=\
o
=
Page:1of1 | Wordsi0 ‘Q% | |I$I$ == 100% (- U (+) |
L )

4. Return to the eFORMz Composer. Highlight the form from the Project Window and

select the Reload Form icon from the toolbar.

-
B Minisoft eFORMz Composer (8.03.08), Licensed to Minisoft, eDIRECT PLU?

File Project Run HostTools Window Help

e]s[ue) »sa(e) ds=]

o v

Project Reload Form = Viewer :
& purchase_order_email Ml view ~| [= Open
¢ B Page1 T
¢ I3 |PurchaseOrder 120 dpi |-

o~ [#] Variables T Page

2~ (@] Rules [ PAGENUM =
o Jj Document Template [IF PONUM = 20
[} DATE = 0311
[0 TERMS = Ne
[F SHIPVIA=PI
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5.

The changes will be updated and shown in the Viewer.

-
B Minisoft eFORMz Composer (8.03.08), Licensed to Minisoft, eDIRECT PLUS Enabled [E=SEN =
File Project Run HostTools Window Help
NEIE
BEEONSEEIEREE]
= —
[ Project = |ZHViewel 7 X
& purchase_order_email | & Open Data|
¢ O Pagel
¢ I PurchaseOrder 12000 | L=EE EMGASTE0_0315_0101.04 = 3708.0:954.0
o [&] variables £ Page =
¢ Bl Rules [} PAGENUM = 01 B
- ]j Document Template [ PONUM = 200000478 =
[ DATE = 03114i12
[ TERMS = Net 30 DAYS —
[} SHIPVIA = PICK-UP
[ FOB = Snohomish
[} DATEREQ1 = 0314/12
[[# VENDORNMUM = VENDOR# MIN290W
¢ [0} vendorAddress
[0 vendoraAddress = JOHN DOE
% shipToAddress
[0f VendorAddress = MINSFT
[0 ShipToAddress -
4 [*]
4 [*] =
Project | eDIRECT PLUS =
[ variables VENDOR FAX NO.
1024 Second Street
Variable Snohomish, Washingten 93290
zbbonblatls
oAz ORDER D. ERMS SHIP VIA FOB.
et | 30 DAYVS 3/14/12 Net 30 DAVS PICK-UP Snohomish
FICK-UE
Snohomiszh
PAYMENT TYPE —
;i;;:éi‘z W SHIPPING INSTRUCTIONS
EMALADDRESS _ |MINZ5uW [v]
VendorAddress(0) JOHN DOE
B teoo Joslwlploo |55 o0 Jd[srlpfor Jimbow  |Thoor |

4 0 |

[+]

PurchaseOrder | PurchaseOrder |
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The Document Template

The Document Template is utilized to place the purchase order total on every
dynamically created page (‘POTotal”). Through the use of the Text to XML
preprocessor, Ecometry’s formatting of page breaks are removed to allow eFORMz
to place as many detail lines as possible to one page. When the detail line count
exceeds a certain number a new page will dynamically be created.

E
B Minisoft eFORMz Composer (8.03.08), Licensed to Minisoft, eDIRECT PLUS Enabled ==

File Project Run HostTools Window Help

-
9 Project ‘ =

& purchase_order_esmail | |ﬁ Open Dma‘
¢ O Pagel

@z [EMCASTE0_0315_ 0101t = 12> 55200 : 5652.0

[OF EXTAMT = 216.00 Il

[0} Description = PRODUCT DESCRIPTION
¢ [ DetailLine

[OF MODELNUM = MM MM 7112

Ot aty =12

[} MEASURE = EACH

[0 DATEREQ = 03114112

[OF UNITPRICE = 7.0000

[F EXTANT = 84.00

[ Description = PRODUCT DESC !

[% POTotal = 444.00

¢ [0f Specialnstructions 3

[ Specialinstruction = Please send order acknowledgement, and confirm Fri [

[ Specialinstruction = day pickup =
4] vl

¢ [ PurchaseOrder
o~ [#] variables
- Rule
¢-{T Document Template
¢ [ Box
¢ [El Paragraph
Ak Content

< [v]
Project | eDIRECT PLUS

] variables

— 1
CPlrenase Orger [Total: s 444.00

Variable

EREQ(1} 03/16/182
EREQ(2) 03/14/12
PRICE(0) 1. 0000
PRICE(1) lz.0000
PRICE(2) 7. 0000
laa.on
zZl6. oo
24.00
Purchalse Drdefs
T D
Purchase{)lder|

nfirm Fri

[4]

I
Dmnn [4[«»[>]oo %nn []«]>[>]o0 igfsso0 |Thesr |

| PurchaseOrder
B
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To edit the position of the Document Template:

1. Right click the Paragraph element and select Edit > Margins.

Project
&4 purchase_order_email View «| |3 Opel
¢ [ Page1 —_—_——
¢ [ PurchaseOrder |‘120 dpi |
o [3] variables O Exramn
o [B] Rules ;
0% Descrip
? JjDocumentTemplate ¢ Ot DetailLine
¢ & Box L
¢-[=] Paragra P
4 Conte ERIEE U
¥ Active B =
Borders g
Add text... ]
Add barcode... b-:l;
Add image... ] Padding 4
Add chart.. v srg;m st
Special
Add... 4 % Spedial
Add AND Condition... »
1] Remaove
| Project l eDIRECT PLUS I"
2. Alter the margins as needed.

L hl
Paragraph Properties u
fGeneraI r Font r Borders r Margins r Padding r Style Id |

[] Mutomatic Margins

Top |5900.0 Bottom (0.0
Left|4050.0 Right|0.0

10

Edit condition OK

‘ Cancel
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EMAIL Address Lookup

Configure a database connection to retrieve the email address corresponding to the
vendor number contained within the data file. To setup or configure your database
connection through eFORMz, right click the Project name and select Properties >
Databases. An SQL Server database name will appear in the Database dialog box. The
SQL Server database can either be configured (Edit) or a new database configuration can
be created (New).

F B
Project Properties ﬂ

[ Printer Control | Sort | Notes | Data Parsing | Advanced | Images | Databases |»

Databases
SQLSever*

MNew

Edit

Remaove

Deactivate

* active in Composer

11
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For this example, select the SQL Server database name and select Edit.

r hl
Configure database connection u

Database connection name|SQLServer

Driver class|com.microsoft. sglserver jdbc. SQLServerDriver

URLtry:selectMethod=cursor;parametersAsUnicode=false

Properties: | Default properties |

[»

Property Value

|applicati0nName ||

|databaseName | |
|bIeStatementF'00Iing||true

[FailoverPariner I

|ostNameInCer1iﬁcate||

instanceMame ||

| Load from file | | Test || oK | ‘ Cancel ‘

Save tofile

[ 4

|
|
|
|encrypt | |tru e |
|
|
|

NOTE: For a list of supported databases and URL and driver classes, view
Appendix B, Database URL and Driver Classes of the eFORMz Manual.
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SQL Lookup

An SQL Lookup has been configured for the ‘EMAILADDRESS’ variable. This lookup
is designed to call the email addresses from the Ecometry database that match the vendor
number contained within the data file.

1. To access the settings, right click the SOQL Lookup and select Edit.
=

Project

¢ [ variables
4E PONUM
ik DATE
ak TERMS

£ SHIPVIA

¥ FOB

¥ DATEREQ1

3

¥

[ 1>

VENDORMUM
EMAILADDRESS
& SOL Looku
VendorAddress Edit...
ShipToAddress :

MODELNUn | ¥ Actve
ary Remove

3
EL
e
2
b
ui
b
Ak MEASURE
Ak
P
EL
gE
2
b

¥
3
"
3
@
u
A
u
A

-

Description
DATEREQ
UNITPRICE
EXTAMT
4] Il T |
Project | eDIRECT PLUS |

4]

2. The settings will display. Edit the SQL statement, if necessary, and enter the correct
table and column the email address resides in. The Parameter added below represents
your database key, in this case, the vendor number is our key.

- .
SQL Lookup (|

Database ‘SOLSE ver ‘ - |

SQL Statement:

@ Constant SELECT EMAIL FROM VENDORDFROM WHERE
ENDORMNO =7

) Variable ‘ |

Parameter

WVENDORMNUM

- Additional columns assigned to

OK | | Cancel |

13
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Sort

1. The sort must be set so that purchase order’s are grouped together and split by the
purchase order number when there are multiple orders in a data file. To do this, right
click the Project and select Properties > Sort.

2. Select the New option to the right of the Sort keys field.
[ Project Properties u1

[ Printer Control [ Sort | Notes | DataParsing | Advanced | Images | Databases |[»

~Sort key

Mave Down

Change Order

* putput grouped by this key

‘ Move Up ‘

Set Grou
[]Inputis in sorted order L

| OK | ‘ Cancel |

h - = = — 4

3. Check the By variable option and select the variable for the purchase order number
(‘PONUM”) from the drop down menu. Choose the Ascending option.

[ Sort Key u

) By farm i@ Byvariable

Key for PurchaseOrder [PONUM |v|

@ Ascending O Descending

oK | ‘ Cancel ‘ i




4. Select the Set Group button. An asterisk will appear after Ascending to indicate it has

been set.
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-
Project Properties

=)

Printer Control | Sort | Notes

Advanced | Images | Databases

rSort keys

variable PONUM:Ascending®

e —

* putput grouped by this key
[ Inputis in sorted order

New

Edit

Remove

Move Up

Move Down

Change Order

o]

Cancel

15



16

Emailing Ecometry Purchase Orders

Emailing an Ecometry Purchase Order
with eFORMz

1. To set up the purchase order template for emailing, switch to the eDIRECT PLUS (or
eDIRECT) tab and select Add Output > E-Mail.

Project = B4
-
Add Output ¥ E-Mail
SMS
Print
Fax
Database
Archive

1]

‘| | »

Project | eDIRECT PLUS |

2. Right click the E-Mail and select Add provider > JavaMail.

[ Project
“~ eDIRECT PLUS

o=
VT Active

Add provider ¥ JavaMail...
Add body eDIRECT PLUS Agent... 1
Add attachment...

Add delivery action
Add AMD Condition... ¥

¥ Group output

Remaove

eDIRECT PLUS




3.

-
JavaMail

Enter values in the respective fields.

-

[ Envelope | SMTP Options |

~SMTP Host

- ) Variable

|emai|.minisoﬂ.c0m

~From

® Constant

) Variable

rTo

|Minisoﬂ, Inc =CustomerSemnvice@minisoft.com=

) Constant

® Variable

[EMAILADDRESS

~CC

M

® Constant

) Variable

@ Constant

() Variable

Subject

i) Constant @ Variable
[PoNUM

|v|

1|

Cancel

4. Right click the E-Mail and select Add attachment.

Project

Ef

Bd

“ eDIRECT PLUS
? mEJ" -
= ¥ Active

Add provider
Add body

Add delivery action
Add AND Condition...

| »

¥ Group output
Remaove
4] [+
eDIRECT PLUS

4
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5. Choose PDF from the drop down menu and navigate to the File tab.

rGenera‘hed Content u1
[ Format | File

Format

IEI

Text
HTML

[»

eFORMz Document
(Color PCL

PCL

ML

Zebra XML

4]

Edit condition ‘ | OK H Cancel ‘

L a4

6. Select the Variable for the purchase order number.

r B
Generated Content ‘ |
Format | File

~File name

) Constant @

[PONUM |~

I [] Create unigue file name Il

~Header

@ Constant () Variable

~Setup
@ Constant () Variable

~Trailer

@ Constant () Variable

|
‘ Edit condition ‘ | oK || Cancel

18
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7. Right click the content and select Add Form(s).

{ B3 Proect

e |

¢ [ E-Mail

o

“ eDIRECTPLUS

i )
e JavaMail
¢ =% Atachments

Content: (PDF)
Edit... »

¥ Active

Add AND Condition... ¥

Remove

-

[*]

eDIRECT PLUS

8. Select the

appropriate form.

r Al
Select formf(s) “x
rForms
rchaseOrder
| OK | ‘ Cancel
L Fl

9. From the eFORMz main menu, select Run > Process w/eDIRECT PLUS (or
eDIRECT) to email the purchase orders.

-
[ Minisoft eFORMz Composer (8.03.08), Licensed to h

File Project Host Tools  Window Help
|B|| e @] Print.. =
= Output...
Project i [}
“ eDIRECT PLUS —
& [ E-Mail
5 JavaMail

¢ =% Attachments
% U Content: (PDF)

Iy PurchaseOrder

19
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Local Toolkit Setup

1.

To set up the purchase order template for automated emailing, open the Local Toolkit
by navigating to the eEFORMz Main Menu and selecting Host Tools > Local Tookit.

The Local Toolkit will display. Right click the configuration and select Add Input >
Directory.

- <
| £ Local Toolkit: Queue Monitors not Running, Licensed to Minisoft, eDIRECT PLUS Enabled (=] B ]
File

Configure | Printers

Configuration

] LocalPM.cfg Add
Add Input... } Directory...
Ri
Change

| »

Mew Configuration Remote directory...
Open Configuration... MQ message queue...

Save Configuration

Save Configuration As...

Logging...

1] [+]

Start Queue Monitor(s) ‘ ‘ Stop Queue Monitor(s)




3. Select the browse button (...) for the /nput Directory and locate the input directory.
This is where the source print file will reside and then be pulled to be merged with
the eFORMz Project. For Ecometry users this is likely the SPOOLOUT directory,
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though eFORMz is capabale of monitoring multiple directories.

r Y
Input Directory u
Name| |
InputDirectory|C:\I'u'linisoﬂ’\eFDRMz_B\lnput || . |
Check Interval (in seconds) |60
Priority Default | |
OK | ‘ Cancel ‘
A

L

4. Right click the Input Directory and choose the Add File Selector option.

B
[é] Local Toolkit: Queue Monitors not Running, Licensed to Minisoft, eDIRECT PLUS Enabled

:

File

Configure | Printers

Configuration

3 LocalPM.cfg

3 Input directory: C:\Minisoftle FORMz_G\nput

I¥T Active

Add File Selector...

Remove

Change...

| »

Im
B 3
= a
o

|

[+]

Remaove

Change

Disable

Start Queue Monitor(s) ‘ | Stop Queue Monitor(s)

21
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5. Enter the print file that has been selected to merge with the eFORMz Project. In
the SPOOLOUT directory, there will be several purchase order data files. In order
for eFORMz to pick up and process them all, they can be wildcarded by using an
asterisk. Also, be sure to check the Append “.hid” to the selected file option. This
retains the extension of the print file, which with Ecometry, refers to the job number

that produced the output.

L hl
File Selection =5
File Selection EM*.J* | | . |

Disposition: ' Change extension of selected file to " hid”
@ Append " hid" to the selected file
() Delete selected file
Additional File Selector |(none) ]
| File Selector Properties |
[] Sortby: @ File name ) Datefime last modified
® Ascending ) Descending
OK | ‘ Cancel ‘

[

]

6. Right click the File Selector, highlight the Add Processor and pick the eFORMz

option.

-
|éé’| Local Toelkit: Queue Monitors mot Running, Licensed to Minisoft, eDIRECT PLUS Ena

File

Configure | Printers

Configuration

3 LocalPM.cfg
¢ 3 Input directory: C:\MinisofieFORMz_G\nput
[ File Selection: PURCH*.I*

¥ Active

Add Processor »

Add Output Process ¥

eFORMz...
Command File

Remaove

Change...

7. Choose the purchase order email.efz project template.

-
Process with eFORMz

=

Project|'emp|ates\Ecometry’npurchaseordenpurchase_order_email.ele| |

OK | ‘ Cancel ‘
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8. Right click the eFORMz Project, highlight Add Output Process and select Process w/
eDIRECT PLUS.

|é| Lacal Toolkit: Queue Monitors not Running, Licensed to Minisoft, eDIRECT PLUS Enabled

File
Configure | Printers

Configuration

3 LocalPM.cfg

¢ ] Input directory: C:\MinisofieFORMz_G\nput
¢ 3 File Selection: PURCH*.J*

[ eFORMz Project. C-\Minis ofteFORMz_B\Projects\SofwareProvider_Temg
¥ Active

Add Output Process #| Print...

Remaove File Qutput...
Change... Process wieDIRECT PLUS...

[ »

9. Enter the directory that will store the email records. Select Disable standard
subdirectories to disable the creation and indexing of new subdirectories for each
batch of emails.

[~ Rl
Process w/eDIRECT PLUS |

ElaseDirectory|:|Iates\RedF’rairie\DiredCommerce\po\purchase_order_email.ele| |

Disable standard subdirectories oK | | Cancel ‘

[t — 4

23
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10. The Local Toolkit has been configured to email RedPrairie Direct Commerce

purchase orders.

-~
| £ Local Toolkit: Queue Monitors not Running, Licensed to Minisoft, eDIRECT PLUS Enabled EIEM

File

Configure | Printers

Configuration

3 LocalPM.cfg
9 7 Input directory: C:\MinisofieFORMz_G\Input
¢ [ File Selection: PURCH®*.J*

3 Process wieDIRECT

¢ ] eFORMz Project: C:\MinisofleFORMz_f\Projects\SofwareProvider_Temy]

-

4] i [

[»]

Start Queue Monitor(s) ‘ ‘ Stop Queue Monitor(s)




