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License Agreement
READ CAREFULLY BEFORE INSTALLING THE MINISOFT SOFTWARE APPLICATION:
CUSTOMER: THE MINISOFT SOFTWARE APPLICATION (“PRODUCT”) THAT YOU PURCHASED CONTAINS COPYRIGHTS, TRADE SECRETS, TRADE MARKS, AND
OTHER INTELLECTUAL PROPERTY RIGHTS BELONGING TO MINISOFT, INC. (“MINISOFT”), HAVING ITS PRINCIPAL OFFICES LOCATED AT 1024 FIRST STREET,
SNOHOMISH, WASHINGTON, 98290, U.S.A. THE PRODUCT MAY BE INSTALLED, COPIED, DISPLAYED, EXECUTED, PERFORMED, OR USED IN ANY OTHER FASHION
ONLY IN ACCORDANCE WITH THE TERMS OF THIS LICENSE AGREEMENT (“AGREEMENT” OR “LICENSE”). THE TERMS “YOU” OR “YOURS” ARE SOMETIMES USED
HEREIN AND MEAN RESPECTIVELY CUSTOMER OR CUSTOMER’S.
SOMETIMES EACH OF MINISOFT AND CUSTOMER IS REFERRED TO HEREIN AS A “PARTY,” AND SOMETIMES THEY ARE COLLECTIVELY REFERRED TO AS THE
“PARTIES.”
YOU MAY NOT INSTALL, COPY, DISPLAY, EXECUTE, PERFORM OR USE IN ANY OTHER FASHION THE PRODUCT EXCEPT IN ACCORDANCE WITH THE TERMS AND
CONDITIONS OF THIS AGREEMENT. IF YOU INSTALL, COPY, DISPLAY, EXECUTE, PERFORM OR OTHERWISE USE ANY PART OF THE PRODUCT, YOU ARE DEEMED
TO HAVE ACCEPTED AND YOU ARE BOUND BY ALL THE TERMS AND CONDITIONS OF THIS MINISOFT LICENSE AGREEMENT (“AGREEMENT”). IN ORDER TO USE
THE PRODUCT, YOU MAY BE REQUIRED TO OBTAIN A UNIQUE CODE OR CODES FROM MINISOFT TO ENABLE INSTALLATION, COPYING, DISPLAY, EXECUTION,
PERFORMANCE AND OTHER USE OF THE SOFTWARE PRODUCT.
IF YOU DO NOT ACCEPT AND AGREE TO THE TERMS AND CONDITIONS OF THIS AGREEMENT, YOU ARE PROHIBITED FROM INSTALLING, COPYING, DISPLAYING,
EXECUTING, PERFORMING, OR USING IN ANY OTHER FASHION THE PRODUCT. VIOLATION OF THIS AGREEMENT (1) CONSTITUTES INFRINGEMENT, MISAPPROPRIATION AND CONVERSION OF MINISOFT’S COPYRIGHTS, TRADE SECRETS, AND OTHER INTELLECTUAL PROPERTY RIGHTS, (2) WILL SUBJECT THE INFRINGER
TO SIGNIFICANT CIVIL LIABILITIES FOR DAMAGES (INCLUDING WITHOUT LIMITATION STATUTORY DAMAGES) AND OTHER REMEDIES AND LIABILITIES, AND (3)
MAY CONSTITUTE VIOLATION OF CRIMINAL LAWS.
IF A CUSTOMER IS PURCHASING AN UPGRADE FOR AN EARLIER VERSION OF THE PRODUCT, THEN THIS AGREEMENT SHALL SUPERSEDE THE TERMS AND CONDITIONS OF THE LICENSE AGREEMENT THAT APPLIED TO THE EARLIER VERSION AS TO THE USE OF THE UPGRADE PRODUCT AS OF THE DATE OF INSTALLATION
OF THE UPGRADE.
NOW, THEREFORE, in consideration of the foregoing provisions and the terms and conditions herein contained and for other good and valuable consideration, the
receipt and sufficiency of which are hereby acknowledged, the following terms and conditions apply:
A. License Grants
1. Upon MINISOFT’s receipt from the Customer of the one-time license fee and further subject to the other terms and conditions herein, MINISOFT grants the Customer
a non-exclusive and non-transferable perpetual license: (a) to install and use the Product on only one host computer or business server in the Customer’s business
organization; and (b) to install the client portion of the Product on a network server for access by more than one personal computer and on any personal computer client
accessing the host server program.
2. You may not: (a) allow access to or use of the Product to anyone outside of your organization; (b) decompile, reverse engineer, decrypt, disassemble, or otherwise
attempt to copy or replicate the source code; (c) modify or translate those portions of the Product that are provided in an object or source code form, or alter, merge,
modify, reverse engineer or adapt the Product in any way including disassembling or decompiling; (d) copy, loan, rent, lease or sublicense, assign, convey, sell, mortgage, pledge, dispose or in any other manner transfer to a third-party any part of or all of the Customer’s rights and obligations under this Agreement or in the Product;
or (e) otherwise copy, distribute, rent, loan, disseminate, publish, sell or transfer any portion of the Product in any way inconsistent with or contrary to the terms and
conditions of the Agreement.
3. Any attempt to violate any prohibitions described in this Agreement shall be considered a material breach of this Agreement, and no attempt to violate section 2(c) or
2(d) in the immediately preceding paragraph shall have any effect, and any prohibited act described therein shall be void and of effect if made by the Customer.
4. You may make one copy of the Product for use as a backup copy (the “Copy”) provided that: (i) the Copy includes all notices of copyright and all other proprietary
rights appearing in and on the Software Product; (ii) the Copy and the original Product are not in use at the SAME time; (iii) Customer establishes a procedure for accounting for the Copy at all times; and (iv) Customer destroys or returns to MINISOFT the Copy when it is no longer required or when the license grants made hereunder
are terminated for any reason, whichever occurs first.
5. This Agreement grants to the Customer a license for use of the Product on the terms and conditions set forth in this Agreement; and (ii) the Customer may not install,
copy, perform, execute, display, or use in any other fashion the Product except in accordance with the terms and conditions of this Agreement. By any use of any element of the Product, the Customer shall be deemed to have accepted and be bound by all the terms and conditions of this Agreement.
6. MINISOFT retains and reserves all rights to the Product. Nothing contained herein shall be deemed to convey to the Customer any title to, or an ownership interest
in, the Product or any of the intellectual property rights contained in the Product. Upon termination of this Agreement, all rights granted to the Customer herein shall
automatically revert to MINISOFT.
B. Termination
The license grants made hereunder shall automatically terminate on the date of any breach by the Customer of any of the terms and conditions of this Agreement. In
any such termination, you shall discontinue using the Product. You further agree to return the Product to MINISOFT or destroy all components of the Product and to
certify in writing that the Product is no longer in use and that you have kept no copies of the Product. In any such termination of the license grants, none of MINISOFT’s
rights in law or equity shall be barred, discharged, released, or otherwise impaired by such termination, and MINISOFT reserves all such rights described herein.
C. Confidential Information
The Product also contains MINISOFT’s commercially valuable, proprietary and confidential information and trade secrets (collectively “Confidential Information”).
You are obligated to preserve and hold in confidence any Confidential Information and may not use any of it except in accordance with the terms and conditions of
this Agreement. Confidential Information shall not include what is already public at the date of its disclosure or what later becomes lawfully public through no fault or
responsibility of the Customer.
D. Limited Warranties and Limitations on Damages and Remedies.
1. Only the limited warranties expressly described in this section are made to the Customer purchasing this Product. No warranty of any kind, whether express or
implied, is made to any third-party or other transferee or successor of the Customer.
2. MINISOFT warrants that it has the right to grant the licenses contained in this Agreement.
3. MINISOFT warrants that this product will execute its programming instructions when properly installed on a properly configured computer for which it is intended.
MINISOFT makes no warranty of any kind, implied or express, that the Product will meet Customer’s requirements or that the Product will be uninterrupted or error-free
4. MINISOFT, Inc. warrants the media upon which this Product is recorded to be free from defects in materials and workmanship under normal use for a period of 90
days from the date of purchase. During the warranty period MINISOFT will replace media that prove to be defective. Customer’s exclusive remedy for any media that
proves to be defective shall be to return the media to MINISOFT for replacement.
5. MINISOFT’ only obligation, liability and/or remedy, with respect to the warranties set forth in this Agreement shall be one of the following, which MINISOFT shall
have sole discretion to choose: (1) as described above, to provide replacement media (whether in the form of the current release or otherwise) for the Product; (2) to
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replace, without charge, the Product with a functionally equivalent software product; or (3) to refund the applicable license fees paid to MINISOFT by Customer. These
are the sole and exclusive remedies for any breach of warranty.
6. MINISOFT shall have no obligation, liability or any other kind of responsibility for the costs of restoring any destroyed or defective data, installation of replacement
media, or software conversion work made necessary by replacement media, even if MINISOFT had been specifically informed by Customer of the possibility or probability of any such consequences. During the ninety (90) days warranty period for the media, MINISOFT will replace, without charge, on an exchange basis, any media which
is not as warranted. Customer must return the defective item postpaid to MINISOFT, postmarked within the time period stated above. Customer must either insure the
defective item being returned or assume the risk of loss or damage in transit. Any claim under the above warranty must include a copy of Customer’s receipt or invoice
or other proof of the date of delivery.
7. Year 2000 Warranty. MINISOFT warrants that the Product will accurately process date/time data (including, but not limited to, calculating, comparing, and sequencing) from, into, and between the twentieth and twenty-first centuries, and the years 1999 and 2000 and leap year calculations, in accordance with the Product’s documentation BUT ONLY to the extent that other technology and systems (e.g., software and operating systems, hardware and firmware) used in combination with the
Product properly exchanges date/time data with it. In addition to the limitations of liability and remedies described above in this Section, the Year 2000 warranty made
herein is made only for ninety (90) days after the date of delivery of the Product and only if any noncompliance is discovered and made known to MINISOFT in writing
within such ninety (90) days. The Year 2000 warranty expires after such ninety (90) day period and shall not extend to any events occurring after the expiration date.
8. MINISOFT makes no other warranty, expressed or implied, with respect to the Product.
9. NOTICE: THE WARRANTIES, OBLIGATIONS AND LIABILITY OF MINISOFT AND THE RIGHTS AND REMEDIES OF CUSTOMER SPECIFICALLY SET FORTH IN THIS
AGREEMENT ARE THE CUSTOMER’S EXCLUSIVE REMEDIES. MINISOFT DISCLAIMS, AND CUSTOMER HEREBY WAIVES, DISCHARGES AND RELEASES MINISOFT,
ITS OFFICERS, DIRECTORS, EMPLOYEES AND AGENTS, FROM ANY AND ALL (1) OTHER WARRANTIES, OBLIGATIONS, OR LIABILITIES AND (2) RIGHTS, CLAIMS,
CAUSES OF ACTIONS, EXPRESS OR IMPLIED, ARISING BY LAW OR OTHERWISE IN CONNECTION WITH, REGARDING, OR ARISING FROM THE PRODUCT OR ANY
RELATED SOFTWARE, TANGIBLE OR INTANGIBLE ITEMS OR SERVICES PROVIDED UNDER THE AGREEMENT (INCLUDING, WITHOUT LIMITATION, ALL DOCUMENTATION SUPPLIED WITH THE PRODUCT). THE WAIVER, DISCHARGE AND RELEASE INCLUDE, BUT ARE NOT LIMITED TO: (1) ANY IMPLIED WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A SPECIFIC PURPOSE; (2) ANY IMPLIED WARRANTY ARISING FROM COURSE OF PERFORMANCE, COURSE OF DEALING, OR
USAGE OF TRADE; AND (3) ANY OBLIGATION, LIABILITY, RIGHT, CLAIM, OR REMEDY, WHETHER IN TORT, CONTRACT, OR OTHERWISE. IN NO CASE SHALL MINISOFT BE LIABLE FOR ANY INCIDENTAL, INDIRECT, SPECIAL, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOSS OF USE, REVENUE, PROFIT,
OR DATA), PUNITIVE DAMAGES, EXEMPLARY OR OTHER STATUTORY DAMAGES, EXPENSES, COSTS (INCLUDING ATTORNEY FEES). IN ADDITION, IN NO CASE
SHALL MINISOFT’S LIABILITY EXCEED THE FEES PAID BY CUSTOMER FOR THE PRODUCT.
E. Updates
Customer is entitled to updates and enhancements to licensed software if under a current Minisoft software update and subscription service. The cost of the update and
subscription service will be 20% of the purchase price of the licensed software. The update and subscription service is for twelve (12) months and can be renewed at the
customer’s discretion.
F. Support Services
A customer that has purchased annual support entitles them to any and all software updates for their licensed product(s) as well as technical support via phone and
email. Software Updates are available from our web site, www.minisoft.com. Included with the purchase of support is the use of our Toll Free 800 number, and support
email. Days and Hours of support coverage are Monday through Friday 7:30am (Pacific) until 5:00pm (Pacific). When support is purchased or renewed, an update may
be downloaded from the Minisoft Website. In cases where support has expired, back-support is charged to bring the support account current. Any supplemental software code provided to you as part of the Support Services shall be considered part of the SOFTWARE PRODUCT and subject to the terms and conditions of this License
Agreement.
G. Miscellaneous
1. Governing Law. This Agreement is made for the sole benefit of the parties hereto, and there are no third party beneficiaries to this Agreement. This Agreement shall
be interpreted under the laws of the State of Washington, notwithstanding the application of any jurisdiction’s choice-of-law rules to the contrary.
2. Independent Contractors. No agency, partnership, joint venture, or employer-employee relationship is created hereby, and neither party nor any of its agents or
employees shall have any authority of any kind to bind the other party in any respect whatsoever. Each party is an independent contractor to the other party.
3. No Assignment by Customer. This Agreement shall be binding upon and inure to the benefit of MINISOFT and any successors and assigns. Customer shall have no
right to assign or otherwise transfer its rights or obligations under this Agreement except with the prior written consent of MINISOFT, which MINISOFT in its sole discretion and for any reason or no reason provide or withhold.
4. Entire Agreement. This Agreement contains the complete understanding between the parties and shall as of the date the Product is first installed supersede all other
agreements, whether they are written or oral, between the parties concerning the particular subject matter. The language of this Agreement shall for all purposes be
construed as a whole, according to its fair meaning, not strictly for or against either party, and without regard to the identity or status of any person who drafted all or
any part of it. No purchase order or any other purchasing instruments issued by Customer, even if such purchase order or other purchasing instrument provides that
it takes precedence over any other agreement between the parties, shall be effective to contradict, modify, delete from or add to the terms of this agreement in any
manner whatsoever.
5. Severability. In the event that any one or more provisions of this Agreement is found by a court of competent jurisdiction to be unenforceable or invalid, then notwithstanding any such finding the remainder of this Agreement shall remain in full force and effect, and such provision that is found to be unenforceable or invalid shall be
deemed severed.
6. Waiver. Neither party’s right to require performance of the other party’s obligations hereunder shall be affected by any previous waiver, forbearance, or course of
dealing, nor shall any waiver or forbearance or other course of dealing at any time with respect to any term or condition in this Agreement be effective unless evidenced
in writing signed by the waiving party as to such waiver, forbearance or other course of dealing. No waiver or modification of this Agreement or any covenant, condition
or limitation herein contained shall be valid and no evidence of waiver or modification shall be offered or received in evidence in any proceeding, arbitration or litigation
between the parties hereto arising out of or affecting this Agreement or the rights or obligations of the parties hereunder, unless such waiver or modification is in writing
duly signed by both parties.
7. Headings, Sections - The various headings in this Agreement are inserted for convenience only and shall not affect the meaning or interpretation of this Agreement or
any Section or provision hereof.
8. Disputes; jurisdiction and venue. Customer and MINISOFT consent to personal jurisdiction, subject matter jurisdiction, and venue in the state and/or federal courts
sitting in King or Snohomish Counties, State of Washington. Any action relating to this Agreement must be brought in the state or federal courts located in King or
Snohomish County, Washington.
9. Attorney’s Fees. In the event legal action is brought by either party to enforce any of the provisions of this Agreement, the prevailing party shall recover its reasonable
attorney’s fees, costs, and expenses, including but not limited to fees, costs and expenses of collecting any judgment.
10. Export. The export of this product is restricted by U.S. export regulations.
11. GOVERNMENT RESTRICTED RIGHTS. The Software Product and documentation are provided with restricted rights. Use, duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c) (2) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252. 227-7013 or subparagraphs (c) (1) and (2) of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/manufacturer is MINISOFT, INC., 1024
FIRST STREET, SNOHOMISH, WASHINGTON, 98290, U.S.A

iv

Table of Contents

Introduction: Overview
The eFORMz Components...................................................................... 13
eFORMz Composer.......................................................................... 13
eDIRECT......................................................................................... 13
eFORMz Director Toolkits................................................................ 14
eReader......................................................................................... 14
OnDemand Printing........................................................................ 14

Chapter 1: Installation Instructions
Printer Recommendations...................................................................... 16
Black/White Printer......................................................................... 16
Color Printer................................................................................... 16
Label Printers................................................................................. 17
eFORMz Client Install............................................................................. 18
Recommendations/Requirements.................................................... 18
Installation / Upgrade Instructions................................................................. 18
Web Install..................................................................................... 18
Host Installation.................................................................................... 19
iSeries/AS400 Host Install....................................................................... 19
Recommendations/Requirements................................................................. 19
Installation and Upgrade Instructions............................................................ 19
Optional Custom eFORMz Job Queue............................................................21
Optional Optimizing..................................................................................... 22
Upgrade Instructions..................................................................................... 24
HPe3000 Install...................................................................................... 25
Recommendation......................................................................................... 25
NetPrint Installation Instructions..................................................... 25
Configure Spooled Devices.............................................................. 26
Installing eFORMz on a Windows Operating System.......................... 26
vi

Unix Environment Install........................................................................ 27
Requirements................................................................................................27
Installation and Upgrade Instructions.............................................................27
Windows Install..................................................................................... 29
Recommendations........................................................................................ 29
Installation Instructions................................................................................. 29
Web Install..................................................................................... 29
Alternative Host-based Processing
(HPe3000, AS400, Unix)........................................................................... 29

Chapter 2: eFORMz Composer
Introduction.......................................................................................... 38
Illustration 1: eFORMz Single Page Project........................................ 39
Illustration 2: eFORMz Two Page Project........................................... 39
eFORMz Composer Tour......................................................................... 40
Getting Started with eFORMz ................................................................ 42
Printing the Sample Project.......................................................................... 44

Chapter 3: Creating an eFORMz Project File
Capturing a Print File / Spoolfile.............................................................. 46
STEP 1.......................................................................................................... 46
Windows Server.............................................................................. 46
AS400 Data Capture........................................................................ 46
HPe3000 Data Capture.................................................................... 49
UNIX Environment Data Capture...................................................... 50
Creating an eFORMz Project................................................................... 52
STEP 2.......................................................................................................... 52
Form Overlay......................................................................................... 59
vii

STEP 3.......................................................................................................... 59
Captured Form Overlay................................................................... 59
Dynamic Form Overlay.................................................................... 61
Project File Printing................................................................................ 62
STEP 4.......................................................................................................... 62

Chapter 4: eFORMz Composer

Data Customization

Customizing your data output.................................................................66
Variables............................................................................................... 67
Creating an eFORMz Variable.................................................................. 67
Positional Data Block Variables......................................................................67
Excluding Data using a Variable........................................................68
Node Data Block Variables.............................................................................70

Chapter 5: Host Project Transfer
iSeries/AS400........................................................................................ 72
HPe3000................................................................................................ 74
UNIX..................................................................................................... 74
Script Command Options................................................................. 80
Windows............................................................................................... 81

viii

Appendix A: Alternate Form

Template Creation

Creating a Form Template File
for eFORMz...................................................................................... 84
Windows XP/2003 Print Driver....................................................................... 84
Windows Vista / 7 / 8 Print Driver................................................................... 86

ix

Introduction

Overview

The Minisoft eFORMz product is designed to provide users with a flexible and dynamic
tool for creating custom forms, documents, and reports. eFORMz is written in 100%
Java and can run on any platform on which Java has been ported.
eFORMz operates on any computer platform that supports JAVA including:
♦

Windows

♦

Unix

♦

Linux

♦

iSeries/AS400

♦

HPe3000*

♦

HP/UX

♦

AIX

♦

Sun/Solaris

♦

Open VMS

eFORMz is also designed to integrate with output from virtually any software
application. Supported applications include: Manhattan Associates, QAD, JDA, STW,
Harris, ManMan, SAP, INFOR, McKesson, Fiserv, JDE, Oracle, Growth Power, Jobscope,
MAPICS, Microsoft Dynamics (AX/NAV/GP), EPICOR, Lawson, NetSuite, HighJump
WMS and many more.

*NOTE: Due to the limitations of JAVA on the HPe3000 we are recommending
to our HPe3000 users to perform the eFORMz/eDIRECT process
on a Windows, Linux, or Unix platform. Contact your Minisoft sales
or support representative (support@minisoft.com) for additional
information.
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The eFORMz Components
eFORMz consists of multiple components, called Client Tools. The Client Tools function
in different methods to support eFORMz for the designing and electronic forms
generation. Below is a brief explanation of each of these components.

eFORMz Composer
The eFORMz Composer manages your form designs and electronic forms output. Data
can be managed and formatted using variables, rules, and formatting options such as
lines per inch, characters per inch, character sets and font style.

eDIRECT
eDIRECT processes output from eFORMz and directs it to one or more different output
destinations including EMAIL, PRINT FILE, and FAX. Using eDIRECT, merged print
files from eFORMz can be redirected to one or more of the above output destinations
simultaneously.

Cross-Reference: For more details, consult the eDIRECT/eDIRECT PLUS Manual.
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eDIRECT+
eDIRECT+ is a feature of eDIRECT with added features and benefits for clients
interested in producing HTML output for emailing (i.e. order or ship confirmations).

Cross-Reference: For more details, consult the eDIRECT/eDIRECT PLUS Manual.

eFORMz Director Toolkits
The Director is an operating system independent Print Monitor. The Director Toolkit is
available for Windows, Linux/Unix, and iSeries/AS400 host systems. It creates a userfriendly environment to configure the eFORMz job process on your host system. With
the Director Toolkits, you can create and modify your form and data merge processes.
Each Director Toolkit configuration can have a separate log file.

Cross-Reference: For more details, consult the Director Manual.

eReader
eReader, the eFORMz Document Viewer, is included with the eFORMz installation.
Smaller and much faster than Adobe Reader, eReader allows eFORMz users to
efficiently print, save and email eFORMz Documents (.efd).

Cross-Reference: For more details, consult the eFORMz - eReader Manual.

OnDemand Printing
The OnDemand Print utility, allows one to enter data as a value via keyboard entry and/
or a scanner. It also includes an option to use a browse button to select file(s) from
specific folders.

Cross-Reference: For more details, consult Appendix C: OnDemand Print Utility
from the eFORMz Reference Manual.
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Installation Instructions

CHAPTER 1

The eFORMz install contains all the necessary components for installing eFORMz on
the client and host systems. To install on a host system you must first install eFORMz
on a client work station (Windows) and then proceed with installation to a host system.
To install on the host systems you will utilize the eFORMz Composer client utility. The
following instructions will explain how to install the client and host system installs.
For clients intending to use eFORMz for printing we have the following
recommendations for printers processing eFORMz output.

Printer Recommendations

eFORMz supports the following printer languages: PCL5, PostScript, XML, AFPDSIPDS, Zebra ZPLll, SCS, Windows GDI and SATO SBPL. eFORMz supports popular
printer manufacturers such as Hewlett Packard, Lexmark, Canon, Toshiba, Ricoh,
IBM, Dell, Brother, Monarch and Datamax. Minisoft recommends the following for
processing eFORMz output on either a black/white printer, color, or label printers.

Black/White Printer
♦

HP LaserJet or equivalent with PCL 5e or greater

♦

Duplex printer for projects requiring duplex printing

♦

MICR cartridge for projects requiring a MICR line
(i.e.:Payroll/Accounts Payable checks)

♦

8-16MB Memory. We recommend 16MB of memory for projects that contain large
amounts of graphics, duplex processing, etc.

Color Printer
eFORMz
Output Type
Image
PCL
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Printer

Operating System

Color Inkjet / Laser Printer

Windows Operating System

PCL 5c Laser Printer required
{ i.e.: HP LJ3800dn }

Windows, HP9000, iSeries\
AS400, Sun, Linux, Windows

Installation Instructions

♦

Duplex printer for projects requiring duplex printing

♦

Black MICR cartridge for projects requiring a MICR line

♦

64MB Memory

♦

16 pages per minute color

Some color printers print 16 pages per minute black/white but only 4 pages per minute
color. Take note of these speeds when choosing a LaserJet printer, otherwise, delays in
the printing process may occur.

Label Printers
eFORMz supports Zebra XML and ZPLII compatible printers. eFORMz also supports
SATO SBPL and Windows GDI (Graphic Image by Driver) for printing NCR 2ST™
thermal labels.

TIP:

For detailed printer recommendations please contact your Minisoft
support representative (support@minisoft.com or (800) 682-0200).
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eFORMz Client Install
Recommendations/Requirements
We recommend a PC with the following minimal requirements:
♦

2 GB RAM or greater

♦

2 GHz or faster

♦

1024x768 with 16 bit resolution

Note: Visit our website for frequently asked questions (FAQ):
www.minisoft.com/pages/business/eformz/pages/eformz-faq.html

NOTE: eFORMz requires Java version 1.7 which is automatically installed
with the PC install. The PC install will not overwrite your system Java
but installs Java in a subfolder under the C:\Minisoft\eFORMz_6\ root
folder.

Installation / Upgrade Instructions
Web Install
From our Minisoft website (www.minisoft.com) please register and download the latest
eFORMz install. Once the setup file has been downloaded to your PC:
1.

Double click the eFORMz executable eFORMz_full.exe and follow the on-screen
instructions. Default install directory is the C:\Minisoft\eFORMz_6\ folder.

NOTE: To install the eFORMz components on your host system (Unix, Linux,
iSeries/AS400, RS6000, HP/UX, Solaris platform) you must first install
eFORMz on your PC. Once the PC install is complete host installs can
now be performed.
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Host Installation
iSeries/AS400 Host Install
Recommendations/Requirements
We recommend the following for AS400’s processing the eFORMz merge:
♦

OS - Version 5 / release level 2 (or greater)

♦

Java - Release 1.6 (or greater)

♦

Recommend creating a holding PrintQ for spoolfiles awaiting eFORMz processes.

Note: For updates to your AS400 Java release please contact your software vendor.

Installation and Upgrade Instructions
The following instructions assume you have already installed the eFORMz Composer on
your PC.
1.

From the eFORMz Composer Menu bar select Host Tools > AS400 > Install eFORMz.

2.

The AS400 Login dialog box will appear. Enter your host IP address, user name, and
password.

3.

Once complete click Connect.

4.

The AS400 Install dialog box will display. By default eFORMz will transfer the
needed jar files from the specified directory in the Install From field:

		

Default: C:\Minisoft\eFORMz_6\

The ‘Install to’ directory can be specified by clicking the browse button for available
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Queues on your AS400 system. By default eFORMz installs into the following
directory off root:
		

/minisoft

Options include:
Include local “fonts” subfolder in copy
Copies the font files located in the following default directory \Minisoft\eFORMz_6\
fonts to the host directory on the AS400.
Clear remote “jars” subfolder before copy
Default checked. Clears the /minisoft/jars/ folder of any default eFORMz .jar files.
Once complete click OK.
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5.

The installation progress bar will display:

6.

Installation is now complete.

Installation Instructions

Optional Custom eFORMz Job Queue
The AS400 is normally delivered with a maximum batch job limit of one, meaning
that only one job can execute at a time. Since the eFORMz Print Monitor runs as a job
(efzPM), if executed and left running no other jobs will run. Instead they will remain in a
‘jobq’ state until the eFORMz PM is terminated.
One option is to increase the maximum job setting value for QBATCH to a value greater
than one. If, however, your jobs require single-thread processing then this may not be
the solution for you.
Another method, which we recommend, is to create a separate job queue to run the
eFORMz Print Monitor. To do so:
1.

Create an eFORMz Library. At the command line enter the following:
CRTLIB				

(To modify: WRKLIB EFZLIB)

Specify the following options:
Name
Type
Text
2.

EFZLIB
*PROD
eFORMz Library

Create an eFORMz Job Queue. At the command line enter the following:
CRTJOBQ			

(To modify: WRKJOBQ)

Specify the following options:
Job Name
Library		
Text		
3.

EFZJOBQ
EFZLIB
eFORMz Job Queue

Create an eFORMz Job Description. At the command line enter the following:
CRTJOBD			

(To modify: WRKJOBD)

Specify the following options:
Job desc.
Library		
Job queue
Library		
4.

EFZJOBD
EFZLIB
EFZJOBQ
EFZLIB

To determine the next available sequence number enter the following at the
command line:
DSPSBSD QBASE
Select option #6 (Job Queue Entries) and check for an unused sequence number.
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5.

Attach a job queue to an active subsystem. At the command line enter the
following:
ADDJOBQE			

(To modify: CHGJOBQE)

Specify the following options:
Subsystem
Library		
Jobqueue
Library		

QBASE
*LIBL
EFZJOBQ
EFZLIB

Max active jobs 1
Seq. number ______
6.

(or number of batch jobs permitted to execute)
(enter value from the previous step)

Create a new eFORMz User. At the command line enter the following:
WRKUSRPRF EFORMZ
Specify the following options:
Option 1
User
EFORMZ
Description
eFORMz User
Password
{ password }
Type of User
*SYSOPR

{System Operator}

Note: We recommend the minimal security level to be *System Operator.
7.

Modify eFORMz Login Profile.
Login as new user (EFORMZ) and make the following changes:
Option		
Option		
Option		
Job description
Library		

1		
9		
F10		
EFZJOBD
EFZLIB

( user task )
( change your user profile )
( additional parameters )

Optional Optimizing
Java applications are interpreted much like “Basic” applications. Interpreted
programming languages are typically slower to execute than ‘compiled’ applications.
The AS400 has an application that converts Java interpreted applications to native
(compiled) code. The command used to convert the Java application is CRTJVAPGM.
This command should be run on all java applications to increase performance. As far as
eFORMz, this means you will need to run this command on the three supplied eFORMz
“.jar” files.
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Depending on the size of your AS400, this operation may take a few minutes or a few
hours. This step is optional but highly recommended as performance will be increased
by a factor of 12.
To convert the AS400 eFORMz jar files that were installed on your host, enter the
following at the command line:
CRTJVAPGM

Set the following:
Class file or JAR file:
Optimization:		

/minisoft/jars/*.jar
30

NOTE: You may want to run CRTJVAPGM as a batch job considering it may take a
considerable amount of time and CPU resources.
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Upgrade Instructions
Before proceeding with an upgrade, we recommend creating a backup directory of
your /minisoft account. The backup directory can easily be created using the following
method from the QSHELL command:
1.

Enter ‘qsh’ ( QSHELL ) from the command line.

2.

To copy the directory, enter:
===> cp -R /minisoft   /minisoft705

3.

Results in two directories:
/minisoft
/miinisoftxxx   { backup }

Should you need to revert back to the original version, delete the existing and move the
old directory back:
==> rm -r /minisoft
==> mv /minisoftxxx /minisoft
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HPe3000 Install
Recommendation
Due to the limitations of JAVA on the HPe3000 we are recommending to our HPe3000
users to perform the eFORMz/eDIRECT process on a Windows operating system. In
combination with NetPrint, Minisoft is providing an automated method to redirect your
spoolfiles from the HPe3000 to print files on Windows.
Follow the instructions below to install NetPrint on your HPe3000 to monitor and
automatically send spoolfiles to a Windows operating system.

NetPrint Installation Instructions
To install NetPrint on your HPe3000:
1.

Insert the eFORMz/NetPrint CD into your CD-ROM drive.

2.

From the Taskbar, select RUN.

3.

Type: D:\NetPrint\NetPrint.exe (D being the letter of your CD-ROM drive) and
follow the on screen instructions.

4

Once NetPrint has been installed, edit your NP92CONF.PUB.MINISOFT file so
NetPrint will send spoolfiles to a Windows operating system.

5.

Add the following statement to your NP92CONF file (example only):
NETPRINT D=LP AND P=3
SETVAR
QUEUE WINEFZ
NODE XXX.XXX.XXX.XX
OPTIONS PTYPE=LPD;PURGE;TRIM;NETOPT=”BSDv”
NETLOG
END

{lowercase V for “BSDv”}

You can modify D=LP to another spool queue device or class name and/or set P=3 to
another priority level. More detailed information concerning selection criteria can be
found in your NetPrint manual.
QUEUE WINEFZ represents the shared print queue configured on your Windows
operating system. Note, they must share the same queue name.
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NODE xxx.xxx.xxx.xx is the IP address of your Windows operating system.
Below is an optional NETOPT configuration for Windows, which changes the file name
sent from the HPe3000 to Windows:
NETOPT=”BSDv, BSDN!SPFNAME-!SPFDFID”

Example:
			

{spoolfile name}-5839_{WINEFZ counter}.dat
INVOICE-5839_1.DAT

Configure Spooled Devices
Setup a dummy device that serves as an output device for the HPe3000’s spool queue.
NetPrint can then act as a spooler process, processing the spoolfiles according to
the specifications set forth in the NetPrint configuration file, NP92CONF. Configure
‘dummy’ spooled devices, using the following method:
Command line (preferred) - adding device/class names via SYSGEN.
:RUN IOCONFIG.PUB.SYS;

INFO=”AD device ID=HPTCPJD CLASS=name PATH=NONE MODE=NONE”
where device = logical device #
name = device class name ( 8 characters)
Samples:
:RUN IOCONFIG.PUB.SYS;

INFO=”AD 900 ID=HPTCPJD CLASS=LJ4 PATH=NONE MODE=NONE”
:OPENQ 900
:RUN IOCONFIG.PUB.SYS;
INFO=”AD 919 ID=HPTCPJD CLASS=HPDSKPAY PATH=NONE MODE=NONE”
:OPENQ 919

Installing eFORMz on a Windows Operating System
Once Netprint has been installed on the HPe3000 you are now ready to install eFORMz
on a Windows operating system. For further instructions on installing eFORMz on
Windows operating system, see Chapter 2: Host Install > Windows Install.
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Unix Environment Install
The eFORMz host install can be installed on a Unix, Linux, HP/UX, RS6000, or Solaris
environment. Follow the installation instructions below to install the eFORMz host
components on one of the above environments.

Requirements
eFORMz requires the following for Unix environments processing the eFORMz merge:
♦

Java - Release 1.6 (or greater)

Installation and Upgrade Instructions
The following instructions assume you have already installed eFORMz on your PC. The
eFORMz Composer will be used to install the needed components on your Unix system.
1.

From your host machine login as Administrator (root) and create the following
directory:
mkdir minisoft

2.

Change the attributes of the Minisoft directory to the following:
chmod 755 minisoft

3.

Open the eFORMz Composer on your PC and select the Host Tools menu. From the
menu selection select Unix > Install eFORMz.

4.

The Unix logon screen will appear. Enter your host IP address, user name, and
password and then click Connect. If using a Secure Shell account, check the Use SSH
option and identify the known_hosts file if necessary.
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5.

The Unix Install dialog box displays. By default, the eFORMz_6 folder is the
directory eFORMz will be selecting the installation files from. The default install
directory on your host system is the minisoft directory under root.

6.

Click OK to start the installation process.

7.

The Progress dialog box will display. When the installation is complete you will
return to the eFORMz Composer main window.

Installation Instructions

Windows Install
Recommendations
To run eFORMz on your Windows Server for the merge process we recommend a server
with the following capabilities:
♦

2GB RAM or greater

♦

2 GHz or faster

NOTE: eFORMz requires Java version 1.7 which is automatically installed
with the PC install. The PC install will not overwrite your system Java
but installs Java in a subfolder under the C:\Minisoft\eFORMz_6\ root
folder.

Installation Instructions
Web Install
From our Minisoft website (www.minisoft.com) please register and download the latest
eFORMz install. Once the setup file has been downloaded to your PC:
1.

Double click the eFORMz executable eFORMz_full.exe and follow the on-screen
instructions. Default install directory is the C:\Minisoft\eFORMz_6\ folder.

Alternative Host-based Processing
(HPe3000, AS400, Unix)
The following instructions are for users sending output from one host system (i.e.:
HPe3000, AS400, Unix) to a Windows operating platform where the eFORMz merge
process will take place. To monitor for incoming print files from another host system
follow these steps.
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STEP 1: Enable TCP/IP Print Server for LPD
Communication
Windows NT
1.

Right-click Network Neighborhood and select Properties.

2.

Select the Services tab. If Microsoft TCP/IP Printing does not appear as a Network
Service click Add.

3.

Click Microsoft TCP/IP Printing and click OK. Insert the source CD-ROM if you are
prompted to do so.

4.

Click Close and restart the computer when prompted to do so.

Windows 2000/XP/2003
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1.

From the Start menu select Settings > Control Panel > Add/Remove Programs.

2.

The Add/Remove Programs dialog box will display.

3.

Click Add/Remove Windows components.

4.

Windows Components Wizard appears.

5.

Click Other Network File and Print Services from the Windows Components Wizard.

Installation Instructions

6.

Click Details. Make sure the option Print Services to UNIX is enabled:

Windows Server 2008
From Server Manager:
1.

Click on Add Roles.

2.

Select Print and Document Services.

3.

Add LPD Services.

Windows VISTA / 7 / 8
From the Start menu select:
1.

Next, enable the LPR Monitor in Windows Features by navigating to Start > Control
Panel > Programs > Programs and Features > “Turn Windows Features on or off.”
Navigate to Print and Document Services, expand the menu and check the LPR Port
Monitor box.
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STEP 2: Starting the TCP/IP Print Server Service
Confirm that the TCP/IP Print Server Service has been started:
1.

From your Windows Control Panel select Administrative Tools.

2.

Select Services. A listing of all services running on your Windows platform will
display.
Windows 2000/XP/2003: Select TCP/IP Print Server.
Windows Vista and later: Select LPD Services.

3.

Start TCP/IP Print Server (or LPD Services depending on your Windows version), if
not started already, and select Automatic as the Startup Type.
Windows 2000/XP/2003

Windows Vista and later
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STEP 3: Configuring the eFORMz Port Monitor
To capture incoming print files (or spoolfiles) from an alternative host system to a
directory on your Windows operating system:
1.

Create a new eFORMz Port by executing one of the two batch files from:

		

C:\Minisoft\eFORMz_6\portmonitor

This directory holds both 32bit (AddPortMonitor.bat) and 64bit
(AddPortMonitor64.bat) versions of the install:

2.

Add a new printer via your Windows Printer Wizard (START Menu > Control Panel >
Printers > Add Printer).

3.

Select LOCAL PRINTER and then click Next.

4.

Choose Create New Printer Port. From the drop down list select eFORMz Port
Monitor. Click Next.
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5.

From the eFORMz Port Monitor dialog box enter the port name and number (id).
We recommend using the format EFZn where n is a value number.

6.

Using the browse button for the Capture Directory field select the folder where you
would like your captured files to reside:

Optional Filename allows you to give the file name a unique name as files are placed
into the capture directory. All files will contain this naming convention with a
automated time stamp:
my_new_template_201307112240263320.zpl
my_new_template_201307112240291480.zpl
my_new_template_201307112240303780.zpl
Record file capture in Event log can remain unchecked. Check Use printer name for
capture file name only if you wish the data file name to replicate the name of the
printer, otherwise, leave unchecked. Check Trace to implement tracing on the port
monitor, leave unchecked.
Click OK when complete.

NOTE: The resulting trace file can be found in the Windows System32 folder
noted as ‘efzmon.tra’.
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7.

Select Generic as the Manufacturer and Generic/Text Only as the Printer type.

8.

Select Keep Existing Driver.

9.

Enter a Printer Name. The printer name should match the QUEUE name that is
specified on your host system sending the print files (spoolfiles) to your Windows
operating system. Once complete your new port will be added:
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STEP 4: Configuring your Network Printers
To avoid print interruptions and to permit print spooling to your network printer
printing an eFORMz merge, make the following change:
1.

From your Printers and Faxes dialog box select the network printer configured to
print your eFORMz merge processes.

2.

Select the Advanced tab.

3.

From the Advanced tab select Start printing after last page is spooled. Click OK.

NOTE: If the printer is in an offline state (paper jam, user offline, out of paper,
etc...) and eFORMz attempts to send print to the queue then Java
complains and the file is not transmitted with the reported error in the
eFORMz log. This issue started appearing with the release of Java 5.
By unchecking the SNMP box, noted above for each and every printer
processed by eFORMz , then the problem goes away. Unfortunately
this box is always checked when one adds a new printer device.
NOTE: Print Spooler must be restarted.
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Introduction
The eFORMz Composer allows you to build, maintain, and manage an eFORMz project
file. A single eFORMz project file can contain any number of forms, variables, and
rules. Each project can contain a number of Logical Pages, with each page containing
a number of Forms. Forms can be created dynamically within eFORMz or using a
preferred word processor, desktop publishing, or drawing package.
Each form can contain a number of Rules. Rules are used to alter the appearance of data
that is displayed on the form. Rules provide you with the options of changing font size
and style, moving data, converting ASCII characters to barcodes, and much more.
The vast majority of projects will only have one logical page even though the actual
print job may contain several physical pages. For example, if you are creating a payroll
print job for your company that consists of 5 employees and the payroll print job simply
prints one check after another, this would be considered a single page project as shown
in Illustration 1.
However, if you are creating a payroll print job for your company that consists of 3
employees and the payroll print job prints a deductions/check followed by an employer
deductions without a check, this would be considered a two page project. This would
allow you to change and edit the two entities separately. See Illustration 2.
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Illustration 1: eFORMz Single Page Project
Logical Page
Minisoft

Physical Pages
Minisoft
Minisoft
Minisoft
Minisoft

Employee
Check Form

Minisoft

Minisoft

Illustration 2: eFORMz Two Page Project
Logical Pages
Minisoft

Physical Pages
Minisoft

Minisoft

Minisoft

Minisoft

Minisoft

Minisoft

Minisoft

Employer Copy
Employee Deductions/Check Form
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eFORMz Composer Tour
The eFORMz Composer consists of two main window area’s, Project and Viewer,
with each having their own distinct functions. The Viewer can be split into two panes
(horizontal or vertical view) with synchronized scroll bars allowing you to customize
your display.

The Project window displays the entire project layout:
♦ project name, pages(s), and form(s)
♦ variables and rules
♦ form and data rule conditions and much more.

The Viewer window displays two main window panes by default:
♦ Input Data Viewer (Data only)

Displays your incoming data. The incoming data is the data you would like to
format or manipulate. The Input Data Viewer is also used to create custom
variables and conditions for use in rule actions.
♦ Form Viewer (Form and Data merged)

Displays your custom form and custom formatted data as it would appear when
printed.
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Vertical Split Pane

Horizontal Split Pane
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Getting Started with eFORMz
To get to know eFORMz start the eFORMz Composer from your Start menu by selecting
Programs > eFORMz 9 > eFORMz Composer. The eFORMz Composer application will
open. To view the applications potential, open one of the sample eFORMz project files.
From the eFORMz Composer File menu:
1.

Select File: Open Project.

2.

The Open dialog box will display. From the Look in field navigate to the following
directory:

		

C:\Minisoft\eFORMz_6\Projects\

Choose a project from one of the following folders:
eDIRECT
sampstm1.efz

Starter eDIRECT project file. Chapter 10: Quick Start

sampstm2.efz

Example project showing how a email or fax
number can be pulled from the data file to be placed
dynamically in eDIRECT.

sampstm3.efz

Example project for database lookup of email address.

eDIRECT+
SAMPLE-1.efz

Sample HTML output order confirmation. Includes
a sample image of the order confirmation (samplelayout.jpg) and the layout in .psd format (samplelayout.psd)

Sample
sampstm.efz*

Sample statement.

sampinv.efz

Sample invoice.

sampchk.efz

Sample check.

samppo.efz

Sample purchase order.

greenbar_landscape.efz

Sample greenbar in landscape format.

greenbar_portrait.efz

Sample greenbar in portrait format.

Software Provider Templates
JDA

Collate, Invoice, Statement

Growth Power

Invoice, Purchase Order

MAPICS

Invoice, Statement

QAD

Purchase Order

*For this example we are opening the sampstm.efz eFORMz project file from the
Sample folder.
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3.

Once the project file has been selected click Open.

4.

The Data File dialog box will display. Select the data file from the Sample folder that
corresponds to the sample project you selected and then select Open.

5.

The eFORMz Composer will now display the project file layout in the Current Project
Window.

TIP:

If the Viewer window does not display as shown above, right click the
project file name from the Current Project Window and select Display
Forms and Data.

43

CHAPTER 2

Printing the Sample Project
To print the sample project file to a networked printer:
1.

From the eFORMz main menu select Run > Print.

2.

The Select Printer dialog box will display. Select the printer you would like to print
to and then select one of the following formats:
Format > PCL (Black and White) - for black/white printing to a LaserJet printer.
Format > PCL (Color) - for color printing to a LaserJet printer.
Format > Postscript - for printing to a Postscript printer.
Format > Image - for printing to a non-pcl based printer.
Format > Zebra XML - for Zebra XML printers.
Format > AFPDS - IBM’s AFPDS/IPDS printers.
Format > ZPLII - for printing to Zebra Programming Language (ZPL II) printers.		
Format > SBPL - for printing to Sato Business Printer Language (SBPL) printers.

3.
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Click OK. The merged form and data will print on your networked printer.
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Capturing a Print File / Spoolfile
STEP 1
The first step to creating and setting up your own eFORMz project file is to capture or
create a test print file (or spoolfile) for implementation in an eFORMz project file. We
recommend a print file containing 3 or more data pages.
The captured print file (or spoolfile) will be used as a template for building your
eFORMz project file. To capture a print file from your host system (Windows, iSeries/
AS400, HPe3000, or Unix environment) for creating an eFORMz project see one of the
following headings pertaining to your host system.
eFORMz supports the following input file types:
♦

XML

♦

EDI

♦

ASCII Text Files

♦

PDF Files

♦

eFORMz Document Files (.efd)

Windows Server
1.

Create an ASCII text file from the Windows application producing your data.

2.

Save the data file to the projects folder containing your eFORMz project file.

3.

We recommend adding a .DAT extension to the file name for easier file selection
from the eFORMz Composer.

AS400 Data Capture
To download a spoolfile for project testing on your PC with eFORMz:
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1.

From the eFORMz Composer select Host Tools > AS400 > Director Toolkit.

2.

The AS400 Login screen appears. Enter your AS400 IP Address, user name, and
password. Once complete click Connect.

3.

The AS400 Toolkit dialog box displays. From the Spoolfiles tab, select the queue the
spoolfile resides in by selecting the Print Queue field. A listing of all print queues will
appear.

Creating an eFORMz Project

4.

Once the queue has been selected click Display. The spoolfiles contained in the
queue display:
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5.

From the list of print files appearing within the queue, select a print file you would
like to download. Once selected click Download.

6.

The Data File dialog box displays. Select the directory you would like to save your
print file to and then enter a new File Name. Once complete click Save.

The print file is now ready for testing with your eFORMz project.
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HPe3000 Data Capture
To capture a spoolfile using NetPrint, simply do the following:
Enter the following command from the PUB.MINISOFT account:
:NPFILE {spoolfile ID # without the O}

The command file instructs NetPrint to create a disk file of your spoolfile minus the
HPe3000 printer control codes. This file, which will match the name of your spoolfile, is
created in the PUB group of your MINISOFT account.
Transfer this file as ‘binary” without file labels or ‘save file info’ selected to the same
directory as your project on your PC. We recommend adding a .DAT extension to the
file name for easier file selection from the eFORMz Composer.
Note: If the NPFILE command is not located on your host system, NPFILE.PUB.
MINISOFT, upload (ASCII transfer) the command file that was placed in the following
directory when eFORMz was installed (NPFILE):
C:\Minisoft\eFORMz_6\doc\
For ESPUL users, upload the ESPFILE command file from this same directory to the
PUB group of the RAC account (ASCII transfer).
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UNIX Environment Data Capture
To download a data file from your Unix system:
1.

From the eFORMz Composer select Host Tools > Unix > Download a file.

2.

If a connection has not already been made, the Unix Login dialog box will display.
Enter your Host IP Address, user name, and password and click Connect.

TIP:
3.
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Upload a data file from your PC using the Host Tools > Unix > Upload a
file option.

The Source File dialog box displays. Select the data file you would like to download
from a directory and click Open.

Creating an eFORMz Project

4.

The Destination File dialog box will display. Specify the directory you would like the
data file to reside in on your PC. Click Save when complete.

5.

After the download process has been completed you will be returned to the main
eFORMz Composer screen.
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Creating an eFORMz Project
STEP 2
Once you have your data file (print file/spoolfile) you now have the components needed
to create an eFORMz project file.
To create a new project:
1.

Select New Project from the eFORMz File menu.

2.

Select File > Save Project As. From the Save dialog enter a new project file name
and click Save.

TIP:

When eFORMz was installed a Projects folder was created in the
following directory:
C:\Minisoft\eFORMz_6\Projects\

We recommend that you create a new folder pertaining to your new
project file and place all components (data file, form template file,
project file, etc.) in this central location for easy access.
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3.

TIP:

4.

From the Current Project Window select your new project file name, right click, and
select Add Page.

A new ‘Page’ represents a new logical page not the number of printed
pages. See Chapter 3 Introduction to eFORMz for a further explanation
on logical pages.
The Page Properties dialog box displays. Enter the number of lines per page and
click OK. A new page folder will appear in the Current Project window, enter a new
name if desired.
If you are unsure of the number of lines per page the Page Properties dialog box can
be updated later.
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TIP:

Lines per page is the number of lines per each data page, default
settings include Portrait = 66 lpi and Landscape = 51 lpi. Setting the lines
per page to zero ( 0 ) indicates form feeds are contained in the data file
and should be used as the data page separator.

5.

Using your mouse, right click your new page and select Add Form.

6.

The Select source of form dialog box displays. Select From file.

NOTE: From file indicates you are going to select a template form that you
created earlier from a form template. Blank indicates you are going
to use an eFORMz blank template which can be set to portrait or
landscape in the Forms Properties dialog box.
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7.

The Open dialog box displays. Select a sample form from the following directory:
C:\Minisoft\eFORMz_6\projects\sample\ sample_statement.rtf

8.

From the Form Properties dialog box make any necessary changes for example:

		

- page size
- orientation
- default font and font size

The Form Properties dialog box can be edited later by right clicking the form name
from the Current Project window and selecting Properties.

Once complete click OK.
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9.

Your form template will now appear in the Current Project window.

10. To reload this form, highlight the form and select the Reload Form button from the
main toolbar. The Reload Form button is configured through System Properties >
Form Editor tab:
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Displaying a Form with Data
1.

To view your form with your test data file (print file/spoolfile) select the project file
name from the Current Project window, right click, and select Display Form and
Data.

2.

Data File dialog box will display. Select the data file you would like to view your
template form with and click Open.
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3.

In the eFORMz Composer Viewer window you should now see a two part window
display. Depending on your Viewer settings one window will contain your incoming
data (test print file/spoolfile) and another window will contain your incoming data
along with your template form merged together.

TIP:

If you would like to view only your template form in the Viewer, from
the Current Project window select the form you would like to display,
right click, and select Display Forms. A new tab will display in the Viewer
displaying your form template.

TIP:

If you would like to open a new data file to test with your current
project file, open a new data file in one of the following ways:
Option 1: Select the project file name from the Current Project window,
right click, and select ‘Open Data File...’. The Data File dialog box will
display. Select a file type and then select the directory your new data
file will resides in. Once completed, select Open.
Option 2: From the Viewer window select the Open Data button. The
Data File dialog box will display. Select a file type and then select the
directory your new data file will resides in. Once completed, select
Open.
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Form Overlay
STEP 3
A form overlay can be applied to your captured data in one of two ways. If you are
replacing a pre-printed form, a form overlay can be a replica of your existing pre-printed
form. The captured form overlay can be created using a word processor, desktop
publishing or drawing package.
eFORMz also has the ability to create dynamic form overlays. Dynamic form overlays
move with your data and can be built and designed from within the eFORMz Composer.
Dynamic form overlays allow you to create forms that move with your data or can be
used in conjunction with creating HTML output. The customized dynamic forms for
HTML output can be customized with urls, links, pictures, and tables. Dynamic forms
can also be used to create free flowing forms.

Captured Form Overlay
A form overlay can be created using a word processor, desktop publishing or drawing
package. If your using Microsoft Word, a Microsoft Word RTF (Rich Text Format) form
can be imported directly into the eFORMz project. For a sample Microsoft Word RTF
document provided by Minisoft, see the following example installed with eFORMz:
\Minisoft\eFORMz_6\Projects\Sample\Sample_Statement.rtf

The Microsoft Word RTF file format can be directly loaded into eFORMz using the Load
Form option from the eFORMz main menu.
If your using an application other than Microsoft Word, capture your form overlay using
the methods described in Appendix A: Alternate Form Template Creation.

TIP:

We recommend designing your form around your data by creating a
blank or “frame form” before adding detailed graphics and text.

59

CHAPTER 3

Example “frame form”
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Dynamic Form Overlay
Dynamic forms can be created through the eFORMz Composer. To implement a
dynamic document, a dynamic component must be added to a form. A dynamic
component includes:
♦

paragraph

♦

table

♦

and box

To include a dynamic component:
1.

Right click your form and select Add Document Component > Paragraph, Table, or
Box:

NOTE: For specific instructions concerning configuring a dynamic form, see
the advanced eFORMz document, eFORMz Mini-Manual > Document
Template:
http://www.minisoft.com/pages/general/manuals/manuals.html
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Project File Printing
STEP 4
To print your merged form and data using the eFORMz Composer:
1.

From the eFORMz main menu select Run > Print.

2.

From the Select Printer dialog box select the printer you would like to print to and
then select one of the following:
Format > PCL to print to a black/white laser printer.
Format > PCL (color) to print to a color pcl printer (i.e. HP LJ3800).
Format > Postscript - to print to any Postscript printer.
Format > Image to print to any laser printer.
Format > Zebra XML to print xml output to a Zebra printer.			
Format > AFPDS to print to any IBM AFPDS/IPDS printer.
Format > ZPLII to print to any Zebra (ZPLII) supported printer.			
Format > SBPL to print to any SATO (SBPL) supported printer.
Black/White Printer Options
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Color Printer Options

The Printer dialog box allows you to print a range of pages. Select Page Range > From
Start or From End. For example, if you would like to print pages 10-20 select Page Range
> From Start:
Start Page = 10
End Page = 20
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If you would like to print pages 10 to the end of a file select Page Range > From Start:
Start Page = 10
End Page = 9999
If, for example, you would like to print all pages minus the last page select Page Range >
From End:
Start Page = 9999
End Page = 1
Also, if you would like to print the last 10 pages of a report select Page Range > From
End:
Start Page = 9
End Page = 0

NOTE: Reverse page numbering starts at zero ( 0, 1, 2, 3, 4, ... ).
If you would like to set a default page range for the project file edit the Project
Properties > Printer Control tab:
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Customizing your data output
eFORMz gives you the ability to customize your data output using variables and
actions. Variables are the primary method used by eFORMz in the customization of
your data output. Variables allow the user to store data for later use and create actions,
functions, and conditions. Any one variable can be used multiple times in a project
layout.
eFORMz supports the following data types for creating and designing variables:
ZPL
XML
XSF
Text
Comma delimited files
AFPDS
PDF
EDI
PCL or PRN
Actions include data placement, barcodes, font sizing and style, and much more.
Functions allow you to further customize your data output by allowing you to do such
things as set values, replace strings and include database lookups. Conditions such as
‘equal to’, ‘not equal to’, ‘less than’, and ‘greater than’ can be applied to both actions
and any form you add to your project layout.
The first step to your data customization is to create a variable. Follow the steps
outlined in the following instructions under Variables > Creating an eFORMz Variable.
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Variables
Creating an eFORMz Variable
The way you create a variable from the eFORMz composer will be dependant on your
data input.

Positional Data Block Variables
1.

From the eFORMz Input Data Viewer, select a string of characters (left click + drag),
right click and select Add Variable.

NOTE: An eFORMz variable can also be created by right clicking on data input
and selecting Add Variable. This method picks up a block of data verses
instead of a specific number of characters. To create an empty variable for
later use, right click the form and select Add Variable > By position.
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2.

The Variable dialog box will display:

3.

Enter a new variable name.

4.

Once complete, click OK.

Excluding Data using a Variable
To exclude data from your output:
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1.

From the eFORMz Input Data Viewer, select the range of data to exclude (left click +
drag), right click and select Add Variable.

2.

The Variable dialog box will display. Enter a new variable name and leave Copy
original data to output unchecked. Once complete, click OK.

eFORMz Composer Data Customization

3.

The newly created variable will display in the Project window. In the eFORMz
Viewer the selected data will no longer appear:

NOTE: If the grid in the Input Data Viewer should need to be hidden for any
reason, right click and select the Grid option. The Adjust Grid dialog box
will display. Uncheck Show Grid. By right clicking in the Form and Data
Viewer its grid may similarly be suppressed.
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Node Data Block Variables
1.

From the eFORMz Input Data Viewer, select the node, right click and select Add
Variable.

2.

The Variable dialog box will display:

Cross-Reference: For more details on Variables, consult the Variables section from
the eFORMz Composer Data Customization chapter of the eFORMz Reference
Manual.
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iSeries/AS400
When you are ready to transfer a project to your host:
1.

Open the project file from within the eFORMz Composer.
From the main task bar select File > Open Project. The Open dialog box will appear.
Select the project file you would like to upload to your host system.

2.

From the Host Tools menu select AS400 > Save Project. The Save dialog box will
display.

NOTE: If you are not already logged in, an AS400 login dialog box will appear.
Select the directory you would like to save your project to (default directory:
minisoft) and then click Save.

Your eFORMz project file will be uploaded to the AS400 directory. If the file already
exists a dialog box will appear asking you if you would like to overwrite the existing file.
Click Yes for overwrite or No to cancel the process.
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To open an existing project located on the AS400 host system:
1.

From the eFORMz Composer main menu select Host Tools > AS400 > Open Project.

2.

The Open dialog box will display. Select the project file you would like to open
from one of the AS400 directories. The Open dialog box defaults to the Minisoft
directory.
Once your project file has been selected click Open.

3.

An open Data File dialog box will display. If you have an existing data file on your PC
select the data file from its directory, otherwise, click Cancel.

4.

Your project file will display in the eFORMz Composer.
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HPe3000
Due to the limitations of JAVA on the HPe3000 we are recommending to our HPe3000
users to perform the eFORMz/eDIRECT process on a Windows, Linux, Unix, or Solaris
platform.

UNIX
To save a project file to your Unix host system:
1.

From the eFORMz Composer open the project you would like to upload to the Unix
host machine (File > Open Project).

2.

Once the project file has been opened, select Host Tools > Unix > Save Project.

3.

The Unix Login dialog box displays. Enter your Host IP Address, user name, and
password and then click Connect.
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4.

The Save dialog box will display. Enter the name you would like the project to have
on the Unix system in the File Name field. By default the project path is the minisoft
directory under root. Click Save.

5.

Once the save has completed you will returned to the eFORMz Composer.

NOTE: After the transfer of the project file to the host system, a change to the
attributes of the project file must take place. From your host machine:
1. Logon as Administrator (root).
2. Change the directory to minisoft.
3. From the minisoft directory change the attributes of the project file:
chmod 755 {project name}.efz
Note, you will also need to do the above attribute change once you
have created the command file.

TIP: A project file can also be opened from the Unix system:
1. From the eFORMz Composer select Host Tools > Unix > Open Project. Login
using your username and password and click Connect.
2. Select the directory where your project file is located and select the project
file you would like to open.
3. Click Open. Your project file appears in the eFORMz Composer. Make the
necessary changes and then select Host Tools > Unix > Save Project to save
your project file back to the Unix system.
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If you are planning on implementing the merge process via a command process use the
following instructions to create a project script file. If you are running the Unix Toolkit
and implementing an automated job process, see Chapter 9 for further information on
implementing the automated job process in which a script file is not needed.
To create the script (.cmd) file:
1.

From the eFORMz Composer main menu select Host Tools > Unix > Save Project
Script.

2.

The Script Builder dialog box will display:

Input Directory
Using the browse button select the directory your data files will reside in to be
merged with an eFORMz project file.
File Selection
Using the browse button select the data file name. Use asterisks (*) for multi data
file selections (i.e. sampstm*.dat or *stm.dat).
Disposition
If you would like the print file to remain in the input directory after a merge has
taken place, select Change extension of selection file to “.hld”.
If you would like the print file to maintain its original extension select Append “.hld”
to the selected file. This will cause the .hld to append to the end of the original
extension.
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If you would like to delete the print file from the input directory after a merge has
taken place, select Delete selected file.
Project
Using the browse button select the project file you would like the data files to be
merged with. Default project directory is /minisoft under root.
Output Process
Output process types include print, file output, and eDIRECT.
Print - Allows you to select the printer you would like to print your merged
output to.
File Output - Allows you to output your merged file to PDF, PCL, PRN, XML,
or another . Using the browse button select the directory you would like your
output to reside in.
eDIRECT - Allows you to specify an eDIRECT process.

Note: Multiple processes can be added to the Output Processes.
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3.

Once your output types have been defined they will appear in the Output Process
field. Use the Add, Edit, or Remove buttons if necessary.

4.

Select the logging format.
Log to stdout - Logs to your display output.
Log to File - Logs all processes to a log file as defined in the Log File field. To set the
log file name and location on the Unix system select the browse icon.

5.

Once complete, click OK.

6.

The Save Script dialog box displays. Enter a command file name (.cmd) and click
Save.
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NOTE: After the transfer of the command file to the host system, a change
to the attributes of the command file must take place. From your host
machine:
1. Logon as Administrator (root).
2. Change the directory to minisoft.
3. From the minisoft directory change the attributes of the project file:
chmod 755 {command file name}.cmd

TIP:

You can also edit an existing script file from a Unix system by selecting
Host Tools > Unix > Edit Project Script. Login to your host system and
select the script file you would like to edit from the specified directory.
The script file will display in the Script Builder. Make the necessary
changes and then click Save.
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Script Command Options
Script Command

Example

-a <filename>

Append to logfile. Example: -a “eformzlog.txt”

-c <directory><filemask>
<copy to directory>

Copy files after output.
Example: -c ”/minisoft/input/*.hld /minisoft/backup”

-d <directory>

Specify input directory. Example: -d ”/minisoft/salesorders”

-e <basedirectory>

Process with eDIRECT. The base directory will be the directory
the eDIRECT output will be sent to.
Example: -e ”/minisoft/invoice/output”

-f <filemask[:disposition>]

Specify file selection and optionally disposition. Optional dispositions include: rename and delete
Example: -f ”inv.data:rename”

-help

-help

-l <filename>

Log to file. Example: -l ”eformzlog.txt”

-n <directory><filemask>
<destination printer>

Print files after output.
Example: -n “/minisoft/output/*.prn roadrunner”

-o <filename>

Output to file. Output file extension options include: .pdf, .prn,
.pcl, .xml.
Example: -o ”inv.pdf”

-p <project>

Specify project file. Example: -p ”sampinv.efz”

-r <directory><filemask>

Delete files after output. Example: -r ”/minisoft/input/*.hld”

-t <printer> or
-tc <color printer>

Printer name. Example: -t ”LJ5si” or -tc “LJ3800DN”

-u <basefilename>

Output to file with unique names. Output file extension options
include: .pdf, .prn, .pcl, .xml.
Example: -u ”inv_.pdf”

-v

Logs to Stdout.

-x <command>

Execute external command after output. Command options:
mv - move command
Example: -x ”mv /minisoft/input/*.hld /minisoft/backup”
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Windows
Transfer your eFORMz project files to a directory on your Windows Server running
the eFORMz merge process. When eFORMz was installed on your Windows Server a
Projects folder was created in the following directory:
C:\Minisoft\eFORMz_6\
Multiple directories can be added to the Projects folder for organizing your eFORMz
project files, for example:
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APPENDIX A

Creating a Form Template File
for eFORMz
To import a form template into the eFORMz project file, you will first need to create
a pcl print file (.prn) of your template. To create a pcl print file, follow the steps below
using the suggested print driver.

Windows XP/2003 Print Driver
1.

Install the HP LaserJet 5Si PCL 5e print driver located in the C:Minisoft\eFORMz_6\
Doc subfolder (NT_2000 5SI Print Driver.exe). The following folder will be created
in the following directory:

		

c:\lj371en

2.

From the Add Printer Wizard proceed with the setup.

3.

Select the Local Printer Option from the Print Wizard.

4.

Select File:Print to File as your Port and click Next.

5.

Select the HPBLFF2.inf file (print driver) from the associated directory (c:\lj371en).
Once selected, click OK.

6.

Click Next.

7.

Enter a Printer Name efzprinter.

8.

Select No if you do not wish this to become your default printer.

9.

Click Finish.

10. The new efzprinter will appear in your printer listing. Right click the efzprinter and
select Properties.
11. From the General tab click Printing Preferences.
12. The Finishing tab will display. Click Details under the Print Quality section.
13. From the Print Quality Details dialog box, select the following:
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Graphic Settings >

Complex Graphics > Use HP MEt

			

Rendering Mode > Send Page as Raster

Alternate Template Creation

Output Settings >

Resolution > 600dpi

				

REt > ON

				

Uncheck > Scale Patterns

				

Check > Print all Text as Black

Font Settings >

Check > Send TrueType as Bitmap

Note: In order to select Send TrueType as Bitmap you must first select Rendering
Mode > Send Graphics as Raster. When Send TrueType as Bitmap has been selected
return settings to Send Page as Raster.

14. When finished click OK.
Note: If you have any questions please contact Minisoft for further advice.
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Windows Vista / 7 / 8 Print Driver
Install the HP LaserJet 5200L Series PCL 5 print driver using the following method:
1.

Create a new printer using the Add Printer option from the Control Panel > Printers
and Faxes dialog box.

2.

From the Add Printer Wizard proceed with the setup.

3.

Select the Local Printer Option from the Print Wizard.

4.

Select File:Print to File as your Port. Click Next.

5.

From the list of manufactures select HP. Select LaserJet 5200L Series PCL 5 as the
model type. Once completed, click OK.

6.

Click Next.

7.

Enter a Printer Name of efzprinter and click Next.

8.

Select No if you do not wish this to become your default printer.

9.

Click Finish.

Once your HP LaserJet 5200L Series PCL 5 print driver has been installed (efzprinter)
click the Properties of this printer from the Printers and Faxes dialog box:
1.

From the Printing Preferences dialog box click the Advanced tab and select the
following options:
Print Optimizations:		
Print All Text as Black:		
Send True Type as Bitmap:
Graphics Mode:			

2.
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When finished click OK.

Disabled
Disabled
Enabled
Send Graphics as Raster
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